tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Draucker <rich...@draucker.com>
Subject Can't import classes from jar
Date Fri, 27 Jul 2001 17:54:58 GMT
I'm not sure I ever tried it before, but I just assumed that as long as a jar 
was in my classpath I could include classes from it.  After upgrading my OS I 
didn't bother copying my supporting class structure:  tomcat/webapps 
/WEB-INF/lib/com.companyname.directory.classes. Instead I just dropped the 
jar file in and pointed to it in the java -classpath.  
When I tried to compile a servlet that included several classes I got an 
error that suggested a bug in jdk1.3.1 with a message telling me to send my 
code and the error to Sun for analysis.  
Scratching around for possible causes led me to try un-jarring the classes 
and voila.  Now I'm wondering if this is correct behavior?  It just seems to 
me the compiler should be able to import those classes without needing them 
outside the jar file.  Comments? 

-- 
Richard Draucker richard@protected-data.com
Protected-Data.Com www.protected-data.com
Remote Data Support For Web Developers


Mime
View raw message