tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Derek Pitts" <de...@mail.chem.tamu.edu>
Subject tomcat wont start
Date Thu, 21 Jun 2001 18:13:02 GMT
Hi,

I am having trouble getting Tomcat 3.2.2 working correctly.
I have tried to install it on two Red Hat Linux 7.0
computers and neither one will function correctly. I have
tried both the rpm and the binary file and I cant seem to
get it to work right. When I run the 

startup.sh or the tomcat.sh start scripts I get this error
message

Using classpath: var/tomcat/lib/*
[root@danna bin]# SIGSEGV 11* segmentation violation
stackbase=(nil), stackpointer=(nil)

Full thread dump:
    NULL (TID:0x4059d0b0, sys_thread_t:0x8083dd8, state:R)
prio=5 *current thread*
java.lang.System.nullInputStream(System.java)
java.lang.System.<clinit>(System.java)
java.lang.String.getChars(String.java)
java.lang.StringBuffer.append(StringBuffer.java)
java.lang.StringBuffer.<init>(StringBuffer.java)
java.lang.Thread.<init>(Thread.java)
Monitor Cache Dump:
    java.lang.Class@1079627864/1079893136: owner NULL
(0x8083dd8, 1 entry)
    java.lang.StringBuffer@1079628136/1079893024: owner NULL
(0x8083dd8, 1 entry)
Registered Monitor Dump:
    Thread queue lock: <unowned>
    Name and type hash table lock: <unowned>
    String intern lock: <unowned>
    JNI pinning lock: <unowned>
    JNI global reference lock: <unowned>
    BinClass lock: <unowned>
    Class loading lock: <unowned>
    Java stack lock: <unowned>
    Code rewrite lock: <unowned>
    Heap lock: <unowned>
    Has finalization queue lock: <unowned>
    Finalize me queue lock: <unowned>
    Dynamic loading lock: owner NULL (0x8083dd8, 1 entry)
    Monitor IO lock: <unowned>
    Child death monitor: <unowned>
    Event monitor: <unowned>
    I/O monitor: <unowned>
    Alarm monitor: <unowned>
    Monitor registry: owner NULL (0x8083dd8, 1 entry)
Thread Alarm Q:

I am fairly certain that this should not happen when I start
tomcat. help would be greatly appreciated. 


Thanks
Derek Pitts
 


Mime
View raw message