tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "LeRoi" <le...@blueyonder.co.uk>
Subject RE: FW: newbie: Starting Tomcat
Date Fri, 15 Jun 2001 10:28:35 GMT
Firstly, a big thanx for the help so far.  I have felt so helpless for the
last couple of days just trying to get Tomcat working.

Jean-Etienne:  I have tried the suggestion of including "jnet.jar" in my
classpath, however, it appears that I don't even have that file in my
"Tomcat" or "Java" directories.

Dimitri: I deleted the test directory and reran "tomcat run" with no
success.  I get the same error message and the test directory is recreated.
I have located several "LocalSTrings_en.properties" files in the following
directories:

E:\jakarta-tomcat-3.2.2\src\org\apache\tomcat\ resources
E:\jakarta-tomcat-3.2.2\\webapps\examples\WEB-INF\classes

Should I move or copy this file somewhere else as well?

Cheers,
LeRoi

-----Original Message-----
From: Dmitri Colebatch [mailto:dim@nuix.com.au]
Sent: 15 June 2001 10:29
To: tomcat-user@jakarta.apache.org
Subject: Re: FW: newbie: Starting Tomcat

The problem here is with the test context, not the server itself.  Have you
possibly removed some files from the %TOMCAT_HOME%\webapps\test directory?
If not, try removing the entire webapps\test directory and restarting.

What is happening is that when the test context is being initialized a
servlet is being loaded on startup that is looking for a resource bundle and
failing (for some reason).  This bindle is from memory in the
test\WEB-INF\classes directory, and by the looks of the exception should be
a
file named "en_US" or something (I think there is a "LocalStrings_en" file
there???).

hope this helps.

cheesr
dim

On Fri, 15 Jun 2001 19:11, you wrote:
> Hello,
>
> I'm new to java and was coming to grips with it until I got to the
> chapter on SERVLETS.  I hope some one out there can help me and I
> would like to thank you in advance.
>
> I downloaded and installed Tomcat 3.2.2 under NT 4.0 (SP 6) without
> any problems.  I also have JDK 1.3 on the machine.  Following one
> posting on "Google" I added the line to the server.xml file:
>         <RequestInterceptor
>             className="org.apache.tomcat.request.Jdk12Interceptor" />
>
>
> When trying to start Tomcat I get the following message:
>
> E:\jakarta-tomcat-3.2.2\bin>tomcat run
> Including all jars in E:\jakarta-tomcat-3.2.2\lib in your CLASSPATH.
>
> Using CLASSPATH:
>
E:\jakarta-tomcat-3.2.2\classes;E:\jakarta-tomcat-3.2.2\lib\ant.jar;E:\jaka
>r ta-tomc
>
at-3.2.2\lib\jasper.jar;E:\jakarta-tomcat-3.2.2\lib\jaxp.jar;E:\jakarta-tom
>c at-3.2.2\lib\parser.jar;
>
E:\jakarta-tomcat-3.2.2\lib\servlet.jar;E:\jakarta-tomcat-3.2.2\lib\webserv
>e r.jar
>
> 2001-06-12 04:16:19 - ContextManager: Adding context Ctx( /examples )
> 2001-06-12 04:16:19 - ContextManager: Adding context Ctx( /admin )
> Starting tomcat. Check logs/tomcat.log for error messages
> 2001-06-12 04:16:19 - ContextManager: Adding context Ctx(  )
> 2001-06-12 04:16:19 - ContextManager: Adding context Ctx( /test )
> Exception in thread "main" java.lang.ExceptionInInitializerError:
> java.util.MissingResourceException
>
> : Can't find bundle for base name javax.servlet.http.LocalStrings,
>
> locale en_US
>         at java.util.ResourceBundle.throwMissingResourceException(Unknown
> Source)
>         at java.util.ResourceBundle.getBundleImpl(Unknown Source)
>         at java.util.ResourceBundle.getBundle(Unknown Source)
>         at javax.servlet.http.HttpServlet.<clinit>(HttpServlet.java:144)
>         at java.lang.Class.newInstance0(Native Method)
>         at java.lang.Class.newInstance(Unknown Source)
>         at
> org.apache.tomcat.core.ServletWrapper.loadServlet(ServletWrapper.java:268)
>         at
> org.apache.tomcat.core.ServletWrapper.init(ServletWrapper.java:289)
>         at
>
org.apache.tomcat.context.LoadOnStartupInterceptor.contextInit(LoadOnStartu
>p Interceptor.j
> ava:130)
>         at
> org.apache.tomcat.core.ContextManager.initContext(ContextManager.java:491)
>         at
> org.apache.tomcat.core.ContextManager.init(ContextManager.java:453)
>         at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:195)
>         at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:235)
> E:\jakarta-tomcat-3.2.2\bin>
>
> If I use "Tomcat Start" or just the "Start.bat" I get a second window that
> opens and disappears rather quickly before I can see what's going on.  Can
> anyone help?  Also, can anyone suggest any books on Tomcat?
>
> Regards,
> LeRoi


Mime
View raw message