tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Filip Hanik" <m...@filip.net>
Subject RE: Classpath problems with Tomcat 3.2
Date Thu, 21 Jun 2001 17:41:52 GMT
what is the URL you are using to access it?
if it is http://dev.jhodd.com/subdir1/subdir2/test.jsp it should work right?

Filip

~
Namaste - I bow to the divine in you
~
Filip Hanik
Software Architect
filip@filip.net
www.filip.net

>-----Original Message-----
>From: Jeffrey Hood [mailto:jhood@hmcon.com]
>Sent: Thursday, June 21, 2001 10:14 AM
>To: tomcat-user@jakarta.apache.org
>Subject: Classpath problems with Tomcat 3.2
>
>
>
>Anyone have -any- explaniation of this???
>
>I can't seem to get the following to work...
>
>entry in server.xml
><Host name="dev.jhood.com" >
>  <Context path="/"
>  		docBase="/home/jhood/dev/websource/tomcat"
>            debug="0"
>		crossContext="false"
>            reloadable="true">
>  </Context>
></Host>
>
>files:
>/home/jhood/dev/websource/tomcat:
>   /WEB-INF
>      /classes
>          test.class
>   /subdir1
>      /subdir2
>
>I have test.jsp in /home/jhood/dev/websource/tomcat, and it finds the
>test.class fine, as well as other classes that test.class uses...  all is
>well...
>
>But if I put test.jsp in /home/jhood/dev/websource/tomcat/subdir1/subdir2,
>the jsp doesn't compile, and the message is that it can't find
>subdir1.subdir2.test to instance it...
>
>Why is it looking for the subdir1.subdir2 package instead of finding it in
>WEB-INF/classes...  do I -have- to have all of my jsp's in the root (can't
>believe that is the case...)
>
>Thanks in advance...
>
>JH
>
>
>
>Jeffrey Hood
>HM Consulting, Inc.
>717.509.6558
>jhood@hmcon.com
>
>
>


Mime
View raw message