tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GOMEZ Henri <hgo...@slib.fr>
Subject [POLL] Tomcat 3.x RPMS : Which XML Parser to be put in ? : WAS : XML parser: old version
Date Fri, 22 Jun 2001 08:41:34 GMT
Hi Sergey,

>With Tomcat 3.2.2 RPMS, I got some XML parser.
>I suspect it is sun's JAXP implementation 1.0. It DOES NOT support
>namespaces (I found it from the error messages:) so it is not possible
>to use XSL in JSPs/Beans/servlets.

That's a known problem. I package these RPMs and asked previously
in tomcat-dev which parser used by default. Some proposed crimson,
others xerces-j (?).

>Will it be any problem to use JAXP 1.1? Or Xerces? What is the current
>policy of using XML parsers in tomcat? Why tomcat does not use Xerces
>having the same Apache licence?
>

I launch that poll to see if which XML parser RPMS users want to
see included by default.

I could add xerces-j 1.4.0 or crimson 1.1 (from xml-crimson CVS or from
http://xml.apache.org/dist/crimson/crimson-1.1.zip)

FYI, I removed on all my sites (which use this RPM), jaxp.jar/parser.jar
and used xerces-j instead !

Mime
View raw message