tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William Kaufman <WKauf...@viquity.com>
Subject RE: URL Help
Date Mon, 04 Jun 2001 22:09:56 GMT
> I can only get it to work if I include 'servlet' like the following:
> 
> http://localhost/Gillette/servlet/Venus?SerialId=ZVXZV&ContactId=1
...
> web.xml:
>     <servlet>
>         <servlet-name>Venus</servlet-name>
>         <servlet-class>GVservlet</servlet-class>
>     </servlet>

Which is the name of your servlet class--"Venus" or "GVservlet"?  (That may
be the problem you're having,...)

                                                            -- Bill K.


> -----Original Message-----
> From: JBrawner@silenus.com [mailto:JBrawner@silenus.com]
> Sent: Monday, June 04, 2001 2:48 PM
> To: tomcat-user@jakarta.apache.org
> Subject: URL Help
> 
> 
> I need my URL to look like this:
> 
> http://localhost/Gillette/Venus?SerialId=ZVXZV&ContactId=1
> where Gillette is a directory and Venus is the servlet name.  
> I can only
> get it to work if I include 'servlet' like the following:
> 
> http://localhost/Gillette/servlet/Venus?SerialId=ZVXZV&ContactId=1
> 
> I've got a few good responses in previous postings but 
> haven't been able to
> get it to work.  Here is some configurations....can anybody 
> tell me what
> I'm doing wrong?
> 
> server.xml:
> <Context path="/Gillette" docBase="webapps/Gillette" 
> crossContext="false"
> debug="0" reloadable="true" ></Context>
> 
> web.xml:
>     <servlet>
>         <servlet-name>Venus</servlet-name>
>         <servlet-class>GVservlet</servlet-class>
>     </servlet>
> 
>     <servlet-mapping>
>       <servlet-name>Venus</servlet-name>
>       <url-pattern>/Venus</url-pattern>
>     </servlet-mapping>
> 
> I've tried it with and without the servlet-mapping tag.  Any ideas?
> 
> 
> Jason E. Brawner
> 

Mime
View raw message