tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas.Rimm...@swissinfo.ch
Subject AW: strange behavior with netscape browser
Date Tue, 19 Jun 2001 19:20:27 GMT
There is no way. It is the first command I call in doGet and doPut.

Greethings, Thomas

-----Urspr√ľngliche Nachricht-----
Von: Filip Hanik [mailto:mail@filip.net]
Gesendet: Tuesday, June 19, 2001 9:07 PM
An: tomcat-user@jakarta.apache.org
Betreff: RE: strange behavior with netscape browser


YOU MUST CALL

respone.setContentType("text/html");

before you write to the output stream.
IE assumes this content type, netscape doesn't

Filip

~
Namaste - I bow to the divine in you
~
Filip Hanik
Software Architect
filip@filip.net
www.filip.net 

>-----Original Message-----
>From: Thomas.Rimmele@swissinfo.ch [mailto:Thomas.Rimmele@swissinfo.ch]
>Sent: Tuesday, June 19, 2001 12:01 PM
>To: tomcat-user@jakarta.apache.org
>Subject: strange behavior with netscape browser
>
>
>Hello,
>
>my application sends strange responses:
>If I try to access the servlet /xobix2/servlet/ONLI
>-everything works fine with IE.
>-Netscape Browser returns the error 404 /xobix2/servlet not found.
>Can anybody imagine why this happens?
>
>I append the corresponding accesslog and a http-header:
>
>Greethings, Thomas Rimmele
>_________________________
>
>HTTP header (Tool: clickbot):
>HTTP/1.1 200 
>Date: Tue, 19 Jun 2001 18:51:34 GMT
>Server: Apache/1.3.17 (Unix) mod_jk
>Set-Cookie2: JSESSIONID=nn82taguz1.w000;Version=1;Discard;Path="/xobix2"
>Set-Cookie: JSESSIONID=nn82taguz1.w000;Path=/xobix2
>Transfer-Encoding: chunked
>Content-Type: text/html
>d19
><HTML>
><HEAD>(...)
>
>
>Access.log (clickbot request)
>146.159.49.128 - - [19/Jun/2001:20:52:48 +0200] "GET /xobix2/servlet/ONLI
>HTTP/1.1" 200 8866
>
>
>Access.log (netscape browser request)
>146.159.49.128 - - [19/Jun/2001:20:43:27 +0200] "GET /xobix2/servlet/ONLI
>HTTP/1.0" 200 8846
>146.159.49.128 - - [19/Jun/2001:20:43:27 +0200] "GET /xobix2/servlet/
>HTTP/1.0" 404 179
>
>Access.log (IE browser request)
>146.159.49.128 - - [19/Jun/2001:20:43:32 +0200] "GET /xobix2/servlet/ONLI
>HTTP/1.1" 200 8866
>146.159.49.128 - - [19/Jun/2001:20:43:32 +0200] "GET
>/template_resources/x2test_dateien/de_swissinfo.gif HTTP/1.1" 304 -
>146.159.49.128 - - [19/Jun/2001:20:43:32 +0200] "GET
>/template_resources/x2test_dateien/deh_map.gif HTTP/1.1" 304 -
>146.159.49.128 - - [19/Jun/2001:20:43:32 +0200] "GET
>/template_resources/x2test_dateien/dot_trans.gif HTTP/1.1" 304 -
>146.159.49.128 - - [19/Jun/2001:20:43:32 +0200] "GET
>/template_resources/x2test_dateien/rand_fussnav.gif HTTP/1.1" 304 -
>146.159.49.128 - - [19/Jun/2001:20:43:32 +0200] "GET
>/template_resources/x2test_dateien/rand_linie.gif HTTP/1.1" 304 -
>146.159.49.128 - - [19/Jun/2001:20:43:32 +0200] "GET
>/template_resources/x2test_dateien/de_rand_fuss_redesign.gif 
>HTTP/1.1" 304 -
>
>


Mime
View raw message