tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brenda Mijares <mijar...@iivip.com>
Subject HELP - Servlets on Apache using JNI
Date Mon, 04 Jun 2001 15:08:39 GMT
I found the following message, yet no reply ... I am having the same
problem except I'm running on Linux..
Does anyone know the solution, to make a basic call to a native method
from a class called from
a servlet??? Do you really need to change the workers.properties file...

*************************************************
From: "Michael Cohen (ETL)"
 Subject:  Tomcat + JNI
 Date:  Fri, 17 Nov 2000 16:58:51 +0100

 Hi,

 I have just installed Apache1.3.14 + modssl + tomcat 3.2b5 on
 Solaris 2.6
 and am trying to call a native method from my servlet (this worked
 fine
 under JavaWebServer2.0).

 The shared library is definitely being loaded (ie no exception is
 thrown when I tried
 to load it separately, the lib is on the LD_LIBRARY_PATH etc) but
 "UnsatisfiedLinkError"
 is still being thrown indicating the implementation of  the native
 method is not
 found.

 I havent done anything special to tomcat for JNI, I was a bit
 baffled by the purpose
 jni_server.xml and jni_workers.properties files! I only need to call
 a C program from
 within a class called by the servlet, don't need to call java
 methods from the native
 code.

 Has anyone come across anything like this?

 Many thanks,

 Mike.

--
Brenda Mijares
Interact Incoporated
email:mijaresb@iivip.com
phone:512-502-9969 ext. 120



Mime
View raw message