tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Kilbride" <j...@kilbride.com>
Subject Re: xtags: Unable to load class
Date Tue, 19 Jun 2001 17:38:13 GMT
Where did you put the taglib tld file and the taglib jar file? What does
your web.xml look like? The order of the definitions in web.xml is also
important. When I first set up my taglibs, I had the <taglib> definition in
my web.xml at the end of the file after a <security-constraint> definition
and it didn't work.

Check out tomcat.mslinn.com for an explanation of the web.xml file.

--jeff

----- Original Message -----
From: "William C. Robertson" <info@bytetherapy.com>
To: <tomcat-user@jakarta.apache.org>
Sent: Monday, June 18, 2001 10:47 PM
Subject: xtags: Unable to load class


>
>
> -----Original Message-----
> From: William C. Robertson [mailto:info@bytetherapy.com]
> Sent: Monday, June 18, 2001 4:37 PM
> To: tomcat-user@jakarta.apache.org
> Subject: xtags: Unable to load class
>
>
> Has anyone else had a problem with taglibs?  I have everything configured
> correctly (pretty sure) and I get the following error when using any of
the
> tomcat taglibs (except for the example tagliv which can with tomcat and
> works fine):
>
> Error: 500
> Location: /examples/init_onlyImports.jsp
> Internal Servlet Error:
>
> org.apache.jasper.compiler.CompileException:
> /usr/local/jakarta-tomcat-3.2.2/webapps/examples/init_onlyImports.jsp(4,0)
> Unable to load class org.apache.taglibs.xtags.tags.ParseTag
> at
> org.apache.jasper.compiler.TagBeginGenerator.init(TagBeginGenerator.java,
> Compiled Code)
>
> I hope the problem is obvious to someone.  Thanks......
>


Mime
View raw message