tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clifford P. Helsel" <chel...@wallstreetwise.com>
Subject RE: FIRST POST - Servlet installation problem
Date Thu, 28 Jun 2001 03:24:18 GMT
Here's my isapi.log... I've commented the parts that seem important...

I know this is a mess but if anyone can take the time to see if there's
something I'm doing wrong I'd greatly appreciate it!

There are some error codes shown but I'm not sure what they are...


[jk_uri_worker_map.c (156)]: Into
jk_uri_worker_map_t::uri_worker_map_alloc
[jk_uri_worker_map.c (196)]: Into
jk_uri_worker_map_t::uri_worker_map_open
[jk_uri_worker_map.c (211)]: jk_uri_worker_map_t::uri_worker_map_open,
rule map size is 3
[jk_uri_worker_map.c (267)]: Into
jk_uri_worker_map_t::uri_worker_map_open, match rule /servlet/=ajp12 was
added
[jk_uri_worker_map.c (267)]: Into
jk_uri_worker_map_t::uri_worker_map_open, match rule /examples/=ajp12
was added

************* Looks like uriworkermap.properties loaded ok
****************

[jk_uri_worker_map.c (267)]: Into
jk_uri_worker_map_t::uri_worker_map_open, match rule /myservlet/=ajp12
was added


[jk_uri_worker_map.c (296)]: Into
jk_uri_worker_map_t::uri_worker_map_open, there are 3 rules
[jk_uri_worker_map.c (317)]: jk_uri_worker_map_t::uri_worker_map_open,
done
[jk_worker.c (82)]: Into wc_open
[jk_worker.c (207)]: Into build_worker_map, creating 2 workers
[jk_worker.c (213)]: build_worker_map, creating worker ajp12
[jk_worker.c (138)]: Into wc_create_worker
[jk_worker.c (152)]: wc_create_worker, about to create instance ajp12 of
ajp12
[jk_ajp12_worker.c (264)]: Into ajp12_worker_factory
[jk_worker.c (161)]: wc_create_worker, about to validate and init ajp12
[jk_ajp12_worker.c (182)]: Into jk_worker_t::validate
[jk_ajp12_worker.c (194)]: In jk_worker_t::validate for worker ajp12
contact is localhost:8007
[jk_worker.c (177)]: wc_create_worker, done
[jk_worker.c (223)]: build_worker_map, removing old ajp12 worker 
[jk_worker.c (213)]: build_worker_map, creating worker ajp13
[jk_worker.c (138)]: Into wc_create_worker
[jk_worker.c (152)]: wc_create_worker, about to create instance ajp13 of
ajp13
[jk_ajp13_worker.c (710)]: Into ajp23_worker_factory
[jk_worker.c (161)]: wc_create_worker, about to validate and init ajp13
[jk_ajp13_worker.c (385)]: Into jk_worker_t::validate
[jk_ajp13_worker.c (398)]: In jk_worker_t::validate for worker ajp13
contact is localhost:8009
[jk_ajp13_worker.c (424)]: Into jk_worker_t::init
[jk_worker.c (177)]: wc_create_worker, done
[jk_worker.c (223)]: build_worker_map, removing old ajp13 worker 
[jk_worker.c (235)]: build_worker_map, done
[jk_worker.c (102)]: wc_open, done

***** Testing redirection of
http://localhost/myservlet/servlet/myservlet 

[jk_isapi_plugin.c (408)]: HttpFilterProc started
[jk_isapi_plugin.c (429)]: In HttpFilterProc test redirection of
/myservlet/servlet/myservlet
[jk_uri_worker_map.c (345)]: Into jk_uri_worker_map_t::map_uri_to_worker
[jk_uri_worker_map.c (407)]: jk_uri_worker_map_t::map_uri_to_worker,
Found a match ajp12
[jk_isapi_plugin.c (439)]: HttpFilterProc [/myservlet/servlet/myservlet]
is a servlet url - should redirect to ajp12
[jk_isapi_plugin.c (461)]: HttpFilterProc check if
[/myservlet/servlet/myservlet] is points to the web-inf directory
[jk_isapi_plugin.c (517)]: HttpExtensionProc started
[jk_worker.c (123)]: Into wc_get_worker_for_name ajp12
[jk_worker.c (127)]: wc_get_worker_for_name, done  found a worker
[jk_isapi_plugin.c (539)]: HttpExtensionProc got a worker for name ajp12
[jk_ajp12_worker.c (223)]: Into jk_worker_t::get_endpoint
[jk_ajp12_worker.c (121)]: Into jk_endpoint_t::service
[jk_connect.c (108)]: Into jk_open_socket
[jk_connect.c (115)]: jk_open_socket, try to connect socket = 2164
[jk_connect.c (124)]: jk_open_socket, after connect ret = -1
[jk_connect.c (143)]: jk_open_socket, connect() failed errno = 61
[jk_ajp12_worker.c (134)]: In jk_endpoint_t::service, sd = -1
[jk_ajp12_worker.c (152)]: In jk_endpoint_t::service, Error sd = -1
[jk_isapi_plugin.c (554)]: HttpExtensionProc error, service() failed
[jk_ajp12_worker.c (163)]: Into jk_endpoint_t::done


***** Testing http://localhost/myservlet/servlet/com.mypackage.myservlet
**
***** Difference is fully specifying package name of Servlet class
*******

[jk_isapi_plugin.c (408)]: HttpFilterProc started
[jk_isapi_plugin.c (429)]: In HttpFilterProc test redirection of
/myservlet/servlet/com.mypackage.myservlet
[jk_uri_worker_map.c (345)]: Into jk_uri_worker_map_t::map_uri_to_worker
[jk_uri_worker_map.c (407)]: jk_uri_worker_map_t::map_uri_to_worker,
Found a match ajp12
[jk_isapi_plugin.c (439)]: HttpFilterProc
[/myservlet/servlet/com.mypackage.myservlet] is a servlet url - should
redirect to ajp12
[jk_isapi_plugin.c (461)]: HttpFilterProc check if
[/myservlet/servlet/com.mypackage.myservlet] is points to the web-inf
directory
[jk_isapi_plugin.c (517)]: HttpExtensionProc started
[jk_worker.c (123)]: Into wc_get_worker_for_name ajp12
[jk_worker.c (127)]: wc_get_worker_for_name, done  found a worker
[jk_isapi_plugin.c (539)]: HttpExtensionProc got a worker for name ajp12
[jk_ajp12_worker.c (223)]: Into jk_worker_t::get_endpoint
[jk_ajp12_worker.c (121)]: Into jk_endpoint_t::service
[jk_connect.c (108)]: Into jk_open_socket
[jk_connect.c (115)]: jk_open_socket, try to connect socket = 2172
[jk_connect.c (124)]: jk_open_socket, after connect ret = -1
[jk_connect.c (143)]: jk_open_socket, connect() failed errno = 61
[jk_ajp12_worker.c (134)]: In jk_endpoint_t::service, sd = -1
[jk_ajp12_worker.c (152)]: In jk_endpoint_t::service, Error sd = -1
[jk_isapi_plugin.c (554)]: HttpExtensionProc error, service() failed
[jk_ajp12_worker.c (163)]: Into jk_endpoint_t::done






-----Original Message-----
From: Peter Harrison [mailto:support@nothingbutnet.co.nz] 
Sent: Wednesday, June 27, 2001 10:58 PM
To: tomcat-user@jakarta.apache.org; chelsel@wallstreetwise.com
Subject: Re: FIRST POST - Servlet installation problem

You need to at least change working.properties file to point to the
correct
directories.


----- Original Message -----
From: "Clifford P. Helsel" <chelsel@wallstreetwise.com>
To: <tomcat-user@jakarta.apache.org>
Sent: Thursday, June 28, 2001 2:46 PM
Subject: RE: FIRST POST - Servlet installation problem


> Hi Jann,
>
> I haven't modified anything in the jakarta-tomcat-3.2.2\conf
directory.
> I have a feeling that I should but I couldn't find anything in the
docs
> that explained what to put there... Am I supposed to modify anything?
> Any pointer to better docs?
>
> Thanks,
> Cliff.
>
>
> -----Original Message-----
> From: Jann VanOver [mailto:Jann.VanOver@loudeye.com]
> Sent: Wednesday, June 27, 2001 10:41 PM
> To: 'tomcat-user@jakarta.apache.org'
> Subject: RE: FIRST POST - Servlet installation problem
>
> Have you added a mapping in Tomcat's urlworkermap.properties file ?
>
> -----Original Message-----
> From: Clifford P. Helsel [mailto:chelsel@wallstreetwise.com]
> Sent: Wednesday, June 27, 2001 7:40 PM
> To: tomcat-user@jakarta.apache.org
> Subject: RE: FIRST POST - Servlet installation problem
> Importance: High
>
>
> This does not solve one problem, that of redirection, or rather
> accessing the Servlet through IIS.  By going to port 8080 I am still
> using the Tomcat engine to serve the page:
>
> For example, in my configuration, this URL works
>
> http://localhost:8080/myservlet/servlet/myservlet
>
> However, this does not (and I would expect it to)
>
> http://localhost/myservlet/servlet/myservlet
>
> Thanks,
> Cliff.
>
> -----Original Message-----
> From: Peter Davison [mailto:peterdavison@home.com]
> Sent: Wednesday, June 27, 2001 10:32 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Re: FIRST POST - Servlet installation problem
>
> Hi Clifford.
>
> Note the lack of :8080 in the URL you mention.
>
> Try this:
>
> http://localhost:8080/servlet/myservlet
>
> and see if that works any better.
>
> P.
>
> CH> I'm using the url: http://localhost/servlet/myservlet
> CH>
>


Mime
View raw message