tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Nance" <Aaron.Na...@southwestern.cc.il.us>
Subject RE: Problems with isapi_redirect.dll
Date Wed, 30 May 2001 20:23:25 GMT
Nope, the ajp12 port is set to 8007 in both files.  I'd have to learn more about the ajp12
protocol, but it looks like it is opening the next available socket to do it's communication
and for whatever reason, my machine won't let it.  I've tried this on a couple of machines
here at work (one NT server and one NT workstation) and get the same results (with different
ports failing each time).  I'm beginning to wonder if is has anything to do with our LAN being
NetWare.  I'm going to try this on my home machine tonight to see if it makes a difference.

Aaron

>>> randy.layman@aswethink.com 05/30/01 02:21PM >>>

	If I had to guess, I would say that Tomcat is not listening on the
correct port (the jk_open_socket fails).  I would check that you have AJP12
configured in your server.xml file and that matches the workers.properties
file.

	Randy


> -----Original Message-----
> From: Aaron Nance [mailto:Aaron.Nance@southwestern.cc.il.us] 
> Sent: Wednesday, May 30, 2001 3:17 PM
> To: aaalmero@its-intl.com.ph; tomcat-user@jakarta.apache.org 
> Subject: RE: Problems with isapi_redirect.dll
> 
> 
> I won't send the entire registry, but here is the Apache key:
> 
> [HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software 
> Foundation\Jakarta Isapi Redirector\1.0]
> "extension_uri"="/jakarta/isapi_redirect.dll"
> "log_file"="D:\\jakarta-tomcat-3.2.2\\logs\\isapi.log"
> "log_level"="debug"
> "worker_file"="D:\\jakarta-tomcat-3.2.2\\conf\\workers.properties"
> "worker_mount_file"="D:\\jakarta-tomcat-3.2.2\\conf\\uriworker
> map.properties"
> 
> Do you see anything wrong with this?  The directories are 
> correct for my setup.
> 
> I also set the log level to debug, and this is what I got:
> 
> [jk_isapi_plugin.c (408)]: HttpFilterProc started
> [jk_isapi_plugin.c (429)]: In HttpFilterProc test redirection 
> of /examples/jsp/index.html
> [jk_uri_worker_map.c (345)]: Into 
> jk_uri_worker_map_t::map_uri_to_worker
> [jk_uri_worker_map.c (407)]: 
> jk_uri_worker_map_t::map_uri_to_worker, Found a match ajp12
> [jk_isapi_plugin.c (439)]: HttpFilterProc 
> [/examples/jsp/index.html] is a servlet url - should redirect to ajp12
> [jk_isapi_plugin.c (461)]: HttpFilterProc check if 
> [/examples/jsp/index.html] is points to the web-inf directory
> [jk_isapi_plugin.c (517)]: HttpExtensionProc started
> [jk_worker.c (123)]: Into wc_get_worker_for_name ajp12
> [jk_worker.c (127)]: wc_get_worker_for_name, done  found a worker
> [jk_isapi_plugin.c (539)]: HttpExtensionProc got a worker for 
> name ajp12
> [jk_ajp12_worker.c (223)]: Into jk_worker_t::get_endpoint
> [jk_ajp12_worker.c (121)]: Into jk_endpoint_t::service
> [jk_connect.c (108)]: Into jk_open_socket
> [jk_connect.c (115)]: jk_open_socket, try to connect socket = 788
> [jk_connect.c (124)]: jk_open_socket, after connect ret = -1
> [jk_connect.c (143)]: jk_open_socket, connect() failed errno = 61
> [jk_ajp12_worker.c (134)]: In jk_endpoint_t::service, sd = -1
> [jk_ajp12_worker.c (152)]: In jk_endpoint_t::service, Error sd = -1
> [jk_isapi_plugin.c (554)]: HttpExtensionProc error, service() failed
> [jk_ajp12_worker.c (163)]: Into jk_endpoint_t::done
> [jk_isapi_plugin.c (408)]: HttpFilterProc started
> [jk_isapi_plugin.c (429)]: In HttpFilterProc test redirection 
> of /examples/jsp/index.html
> [jk_uri_worker_map.c (345)]: Into 
> jk_uri_worker_map_t::map_uri_to_worker
> [jk_uri_worker_map.c (407)]: 
> jk_uri_worker_map_t::map_uri_to_worker, Found a match ajp12
> [jk_isapi_plugin.c (439)]: HttpFilterProc 
> [/examples/jsp/index.html] is a servlet url - should redirect to ajp12
> [jk_isapi_plugin.c (461)]: HttpFilterProc check if 
> [/examples/jsp/index.html] is points to the web-inf directory
> [jk_isapi_plugin.c (517)]: HttpExtensionProc started
> [jk_worker.c (123)]: Into wc_get_worker_for_name ajp12
> [jk_worker.c (127)]: wc_get_worker_for_name, done  found a worker
> [jk_isapi_plugin.c (539)]: HttpExtensionProc got a worker for 
> name ajp12
> [jk_ajp12_worker.c (223)]: Into jk_worker_t::get_endpoint
> [jk_ajp12_worker.c (121)]: Into jk_endpoint_t::service
> [jk_connect.c (108)]: Into jk_open_socket
> [jk_connect.c (115)]: jk_open_socket, try to connect socket = 768
> [jk_connect.c (124)]: jk_open_socket, after connect ret = -1
> [jk_connect.c (143)]: jk_open_socket, connect() failed errno = 61
> [jk_ajp12_worker.c (134)]: In jk_endpoint_t::service, sd = -1
> [jk_ajp12_worker.c (152)]: In jk_endpoint_t::service, Error sd = -1
> [jk_isapi_plugin.c (554)]: HttpExtensionProc error, service() failed
> [jk_ajp12_worker.c (163)]: Into jk_endpoint_t::done
> 
> Any ideas?
> 
> Aaron
> 
> 
> >>> aaalmero@its-intl.com.ph 05/27/01 07:58PM >>>
> i also encountered several problems while configuring tomcat 
> work IIS and
> after 3 days i have it working perfectly with the same config 
> as yours. can
> you send me your registry file?  maybe theres something wrong with it.
> 
> -----Original Message-----
> From: Aaron Nance [mailto:Aaron.Nance@southwestern.cc.il.us] 
> Sent: Saturday, 26 May 2001 8:33 AM
> To: >
> Subject: Problems with isapi_redirect.dll
> 
> 
> Everyone,
> 
> I am having problems getting isapi_redirect.dll to work.  Here's my
> configuration info:
> 
>   Win NT Server: SP 6a
>   IIS 4
>   Java 1.3.0-c
>   Tomcat 3.2.1
>   
> I have no problem running Tomcat in stand alone mode.  I am 
> 99.9 % certain I
> have the registry entries right.  When I try to access
> http://localhost/examples/jsp/index.html IIS throws a 500 at 
> me.  I get the
> following information in the isapi.log:
> 
>   [jk_uri_worker_map.c (334)]: 
> jk_uri_worker_map_t::uri_worker_map_close,
> NULL parameter
>   [jk_uri_worker_map.c (184)]: In 
> jk_uri_worker_map_t::uri_worker_map_free,
> NULL parameters
>   [jk_connect.c (143)]: jk_open_socket, connect() failed errno = 61
>   [jk_ajp12_worker.c (152)]: In jk_endpoint_t::service, Error sd = -1
>   [jk_isapi_plugin.c (554)]: HttpExtensionProc error, service() failed
> 
> I'm running with the configuration files as they were 
> installed by Tomcat
> except for the workers.tomcat_home and workers.java_home 
> properties in the
> workers.properties file.
> 
> If you can tell me what I'm doing wrong here I'd appreciate it.
> 
> Thanks,
> Aaron
> 

Mime
View raw message