tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r...@harlequin.co.uk
Subject mod_jk broken for Apache 2.0 was Re: Failure to compile mod_jk on Solaris
Date Wed, 09 May 2001 11:52:07 GMT
Having looked through all the docs and CVS, it seems that the include file in
question was from an older version of Apache.

Is it best to use 1.3.19? Does mod_jk work at all with Apache 2.0? Is it best to
use Linux?

At 5/9/2001 10:57:56 AM, Roger Day wrote:
#  A newbie question, I fear.
#
#  In trying to compile mod_jk.c from Tomcat 3.2.1 against Apache 2.0.16 on
Solaris
#  2.7, I get the following message:
#
#  ~/local/apache/bin/apxs -o mod_jk.so -DSOLARIS -I../jk -I/usr/java/include
#  -I/usr/java/include/solaris -c *.c ../jk/*.c
#  libtool --silent --mode=compile gcc  -I/u/rday/local/apache/include -I../jk
#  -I/usr/java/include -I/usr/java/include/solaris -DSOLARIS  -c mod_jk.c &&
touch
#  mod_jk.slo
#  mod_jk.c:76: http_conf_globals.h: No such file or directory
#  apxs:Break: Command failed with rc=65536
#
#  I'm assuming that the file should be in the apache include, but isn't. Is
there
#  another place it should be?
#
#  I've looked in the mail archive and the FAQ but I can't see any mention of
this
#  problem - could someone point me at the right part of the FAQ, please?
#
#  Roger
#
#
Roger



Mime
View raw message