tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William Kaufman <WKauf...@viquity.com>
Subject RE: Using JDBCRealms
Date Tue, 29 May 2001 21:16:19 GMT
It turned out I was being an idiot: I modified tomcat/conf/server.xml, where
our batch file was actually executing Tomcat with "-f
/some/where/else/server.xml".  Once I put it in the right file, everything
worked fine, so I don't know how much help my responses would be.  (You
could look through the archives at one of,

    http://tomcat.mslinn.com/
    http://marc.theaimsgroup.com/?l=tomcat-user&r=1&w=2

Maybe you should post the problem(s) you're having, and whatever debug info
you're getting,...

                                                            -- Bill K.


> -----Original Message-----
> From: Ben Sifuentes [mailto:bsifuentes@cysive.com]
> Sent: Tuesday, May 29, 2001 7:49 AM
> To: tomcat-user@jakarta.apache.org
> Subject: RE: Using JDBCRealms
> 
> 
> I'm trying to utilize teh JDBCRealm also. I see you are 
> trying to get some
> of the same information I am. Did you get a response for your 
> previos e-mail
> 
> -Ben
> 
> -----Original Message-----
> From: William Kaufman [mailto:WKaufman@viquity.com]
> Sent: Friday, March 16, 2001 8:05 PM
> To: Tomcat Users (E-mail)
> Subject: Using JDBCRealms
> 
> 
> (Tomcat version 3.2.1.)
> 
> I'm trying to use JDBCRealm to manage access to some static 
> files.  Is there
> any documentation for that?
> 
> I've successfully configured authorization in web.xml (though 
> it only seems
> to work if the files are under webapps/ROOT--that's OK for 
> what I'm doing,
> but I am curious about why that is).
> 
> But I can't seem to get JDBCRealm (or my own subclass of that) to get
> called.  I've added,
> 
>     <RequestInterceptor
>         className="org.apache.tomcat.request.JDBCRealm"
>         debug="99"
>         driverName="oracle.jdbc.driver.OracleDriver"
>         connectionURL="jdbc:oracle:thin:@localhost:1521:adb"
>         connectionName="metax"
>         connectionPassword="tiger"
>         userTable="contacts"
>         userNameCol="username"
>         userCredCol="password"
>         userRoleTable="user_roles"
>         roleNameCol="role" />
> 
> to my conf\server.xml, and commented out the SimpleRealm interceptor.
> JDBCRealm is on my classpath--"javap" can print it.  And that JDBC
> connection works fine outside of JDBCRealms, so it's not a JDBC issue.
> 
> Near as I can figure, Tomcat isn't even loading the class.  
> Is there some
> debugging I can turn on in Tomcat to see what's going wrong?
> 
>                                                             -- Bill K.
> 

Mime
View raw message