tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Watson <jwatson...@earthlink.net>
Subject Re: WAP
Date Tue, 08 May 2001 19:58:06 GMT
Arthur,

Thanks very much.  That's got it! - jim

At 10:45 AM 5/8/01 +0200, you wrote:
>Hi jim,
>first of all do you use Tomact as stand alone or with Apache ?
>if the answer is : Stand Alone
>1) to serve wml (static file), you need to add the mime type to WEB-INF
>directory under your application
>the server.xml (under c:\jakarta-tomcat\conf) should have some thing like
><Context path="" docBase="the root for your application" debug="1"
>reloadable="false" trusted="true"/>
>2) to serve wml (dynamic page with jsp) you need to add the mime type to
>WEB-INF directory under your application
>and put <%@ page contentType="text/vnd.wap.wml" %> on every page
>
>if the answer is : With Apache
>if you want to serve only static wml pages just add the mime types to
>mime.type under Apache
>
>hope this helps
>Arthur
>
>----- Original Message -----
>From: "Jim Watson" <jwatson209@earthlink.net>
>To: <tomcat-user@jakarta.apache.org>
>Sent: Monday, May 07, 2001 7:59 PM
>Subject: Re: WAP
>
>
> > Arthur,
> >
> > I am getting a similar error message to Odd.Olsen, but using Tomcat in
> > conjunction with the UP.Simulator vice Nokia.  I am attempting to get the
> > UP.Simulator to access .wml files on Tomcat using
> > http://localhost:8080/<static.wml file>.  I have added the mime-types to
> > the (in my case) c:\jakarta-tomcat\conf\web.xml file without success
> > (Odd.Olsen's problem).  Netscape and IE both work fine with my Tomcat
> > localhost:8080 installation.  This seems to be a special case with respect
> > to your recommendation to add the mime types to the
> > yourApplication/web-inf/web.xml file.  I have added the wap mime-types to
> > the c:\jakarta-tomcat\webapps\examples\Web-inf\web.xml file with the same
> > (error) result.  Can you suggest any fixes in this case?  thanks - jim
> >
> > At 09:49 AM 5/7/01 +0200, you wrote:
> > >Hi,
> > >there is a bug in tc 3.2,
> > >you have to put the mime types in the web.xml under your application
> > >
> > >yourApplication/web-inf/web.eml
> > >
> > >Arthur
> > >----- Original Message -----
> > >From: "Olsen Odd" <Odd.Olsen@volvo.com>
> > >To: <tomcat-user@jakarta.apache.org>
> > >Sent: Monday, May 07, 2001 8:10 AM
> > >Subject: WAP
> > >
> > >
> > > > Hi
> > > >
> > > > When I try to run WML on Tomcat 3.2, I get
> > > >   MIME type "text/plain" is not supported
> > > >
> > > > I have put the mime types for WML in /conf/web.xml
> > > > as you can see below and is using Nokia WAP Toolkit.
> > > >
> > > > It all worked great when I use Tomcat 3.1 and I can't see
> > > > why it shouldn't work on 3.2. What more I can do?
> > > >
> > > > /Odd
> > > >
> > > > <!-- Start WAP extensions -->
> > > >     <mime-mapping>
> > > >         <extension>wml</extension>
> > > >         <mime-type>text/vnd.wap.wml</mime-type>
> > > >     </mime-mapping>
> > > >     <mime-mapping>
> > > >         <extension>
> > > >             wbmp
> > > >         </extension>
> > > >         <mime-type>
> > > >             image/vnd.wap.wbmp
> > > >         </mime-type>
> > > >     </mime-mapping>
> > > >     <mime-mapping>
> > > >         <extension>
> > > >             wmlc
> > > >         </extension>
> > > >         <mime-type>
> > > >             application/vnd.wap.wmlc
> > > >         </mime-type>
> > > >     </mime-mapping>
> > > >     <mime-mapping>
> > > >         <extension>
> > > >             wmls
> > > >         </extension>
> > > >         <mime-type>
> > > >             text/vnd.wap.wmlscript
> > > >         </mime-type>
> > > >     </mime-mapping>
> > > >     <mime-mapping>
> > > >         <extension>
> > > >             wmlsc
> > > >         </extension>
> > > >         <mime-type>
> > > >             application/vnd.wap.wmlscriptc
> > > >         </mime-type>
> > > >     </mime-mapping>
> > > > <!-- End WAP extensions -->
> > > > _________________________________________________
> > > > Odd Olsen
> > > > Volvo IT
> > > > Dept 2540, DA2N
> > > > SE-40508 Goteborg, Sweden
> > > >
> > > > Telephone: +46 31 7655718
> > > > E-mail: Odd.Olsen@volvo.com
> > > >
> > > >
> >
> > Jim Watson
> > jwatson@gmu.edu
> > jwatson209@earthlink.net
> >

Jim Watson
jwatson@gmu.edu
jwatson209@earthlink.net


Mime
View raw message