tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jack Lauman <jlau...@nwcascades.com>
Subject Re: openbsd and mod_jk.so build problem
Date Sat, 26 May 2001 16:17:42 GMT
I had the same problem with JDK1.3.1rc2... It's looking for jni.h and
jni_md.h.  I put them in /usr/include and the problem went away.

Hope it helps,

Jack

joan wrote:
> 
> hey,
> I tried to build mod_jk.so on openbsd but I failed...
> My environment is as follows:
>   * OpenBSD 2.8 Current/ i386
>   * JDK 1.1.8 (built from ports)
>   * Tomcat 3.2.1
> 
> I used from
> /usr/local/jakarta/jakarta-tomcat-3.2.1-src/src/native/apache1.3
> 
> root@localhost#/usr/sbin/apxs -c -I/usr/local/jdk1.1.8/include
> -I/usr/local/jdk1.1.8/include/freebsd -DFREEBSD -I/usr/lib/apache/include
> -I../jk mod_jk.c ../jk/*.c
> 
> and the output was:
> cc -O2 -DDEV_RANDOM=/dev/arandom -DMOD_SSL=206106 -DEAPI -DUSE_EXPAT -I../li
> b/expat-lite -fPIC -DSHARED_MODULE -I/usr/lib/apache/include -I/usr/local/jd
> k1.1.8/include -I/usr/local/jdk1.1.8/include/freebsd -I/usr/lib/apache/inclu
> de -I../jk -DFREEBSD  -c mod_jk.c
> cc -O2 -DDEV_RANDOM=/dev/arandom -DMOD_SSL=206106 -DEAPI -DUSE_EXPAT -I../li
> b/expat-lite -fPIC -DSHARED_MODULE -I/usr/lib/apache/include -I/usr/local/jd
> k1.1.8/include -I/usr/local/jdk1.1.8/include/freebsd -I/usr/lib/apache/inclu
> de -I../jk -DFREEBSD  -c ../jk/jk_ajp12_worker.c
> cc -O2 -DDEV_RANDOM=/dev/arandom -DMOD_SSL=206106 -DEAPI -DUSE_EXPAT -I../li
> b/expat-lite -fPIC -DSHARED_MODULE -I/usr/lib/apache/include -I/usr/local/jd
> k1.1.8/include -I/usr/local/jdk1.1.8/include/freebsd -I/usr/lib/apache/inclu
> de -I../jk -DFREEBSD  -c ../jk/jk_ajp13.c
> cc -O2 -DDEV_RANDOM=/dev/arandom -DMOD_SSL=206106 -DEAPI -DUSE_EXPAT -I../li
> b/expat-lite -fPIC -DSHARED_MODULE -I/usr/lib/apache/include -I/usr/local/jd
> k1.1.8/include -I/usr/local/jdk1.1.8/include/freebsd -I/usr/lib/apache/inclu
> de -I../jk -DFREEBSD  -c ../jk/jk_ajp13_worker.c
> cc -O2 -DDEV_RANDOM=/dev/arandom -DMOD_SSL=206106 -DEAPI -DUSE_EXPAT -I../li
> b/expat-lite -fPIC -DSHARED_MODULE -I/usr/lib/apache/include -I/usr/local/jd
> k1.1.8/include -I/usr/local/jdk1.1.8/include/freebsd -I/usr/lib/apache/inclu
> de -I../jk -DFREEBSD  -c ../jk/jk_connect.c
> cc -O2 -DDEV_RANDOM=/dev/arandom -DMOD_SSL=206106 -DEAPI -DUSE_EXPAT -I../li
> b/expat-lite -fPIC -DSHARED_MODULE -I/usr/lib/apache/include -I/usr/local/jd
> k1.1.8/include -I/usr/local/jdk1.1.8/include/freebsd -I/usr/lib/apache/inclu
> de -I../jk -DFREEBSD  -c ../jk/jk_jni_worker.c
> ../jk/jk_jni_worker.c:764: warning:
> #warning -------------------------------------------------------
> ../jk/jk_jni_worker.c:765: warning: #warning NO JAVA 2 HEADERS! SUPPORT FOR
> JAVA 2 FEATURES DISABLED
> ../jk/jk_jni_worker.c:766: warning:
> #warning -------------------------------------------------------
> ../jk/jk_jni_worker.c: In function `load_jvm_dll':
> ../jk/jk_jni_worker.c:724: `RTLD_NOW' undeclared (first use in this
> function)
> ../jk/jk_jni_worker.c:724: (Each undeclared identifier is reported only once
> ../jk/jk_jni_worker.c:724: for each function it appears in.)
> ../jk/jk_jni_worker.c:724: `RTLD_GLOBAL' undeclared (first use in this
> function)
> apxs:Break: Command failed with rc=65536
> root@localhost#
> 
> I searched all the mailing list but I did not found the solution...
> Tue, 06 Feb 2001,Tobias Oberstein wrote a similar message but no good
> response was replied...
> 
> On Freebsd 4.3 Released I've successfully built a working mod_jk.so.
> The shell script with tomcat-3.2.1 is buggy on freebsd but works well on
> linux.
> So I used the apxs command that fails for openbsd and that is described at
> the beginning of the message....
> 
> So, is there anyone who succesfully built mod_jk.so on openbsd?
> Please help me...
> 
> Thanks

Mime
View raw message