tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Noel E. Lecaros" <spo...@mozcom.com>
Subject Re: wired CLASSPATH behaviour
Date Mon, 07 May 2001 10:02:09 GMT
Hi, Roman

Just a thought, but have you tried RENAMING the file db2java.zip to db2java.jar?

Regards,
Noel Lecaros

"Gerteis, Roman" wrote:
> 
> Hay there,
> 
> when I was deploying a application on Tomcat 3.2.1 we had some really wired
> Problems with CLASSPATH issues.
> 
> First of all this is the environment:
> * apache 1.3.14
> * mod_jk.so
> * tomcat 3.2.1
> on Redhat 6.2
> JVM 1.3 (Sun distribution)
> 
> ok. So we were putting JDBC Drivers of IBM (db2java.zip) on various places
> where we should be able to put them.
> 
> 1. we put it into the $TOMCAT_HOME/lib/ to be include for whole tomcat. (did
> not work)
> 2. we put it into the CLASSPATH environment inside the
> $TOMCAT_HOME/tomcat.sh script (did not work)
> 3. we put it into $TOMCAT_HOME/webapps/our_app/WEB-INF/lib/ (did not work)
> 4. we unpacked the zip file and put the package tree under
> $TOMCAT_HOME/webapps/our_app/WEB-INF/classes/ --> YUHEE, it worked.
> 
> the depressing part of it was, that db2java.zip and the _right_ Path to it
> was shown in the CLASSPATH variable on every of the setups
> (System.out.println, or shellscript ECHO). But the JDBC Driver Manager
> dumped no suitable driver found.
> 
> It took me quite a lot of time to make the application run, cause there was
> no reason for the failure (If you have a package in your classpath, then you
> would suggest that it is loaded, right?).
> 
> Anyways. The whole adventure brings me to the conclusion that either the
> CLASSPATH environment of Sun JDK 1.3 for Linux is not working properly or ..
> the dynamic loading of packages of TomCat is not fully reliable (which I
> honestly do not believe).
> 
> Does anyone had similar Problems, and can someone give me a tip for where to
> put JDBC Driver packages inside a Webapp? (WEB-INF/lib/ I thought, but....)
> 
> thx. and regards
> roman

Mime
View raw message