tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Crouch <mcro...@knowledgemechanics.com>
Subject Re: mod_jk build on Solaris
Date Wed, 02 May 2001 16:52:47 GMT
I tried updating the apxs perl script with the following:

my $CFG_TARGET        = 'q(httpd)';            # substituted via
Makefile.tmpl 
my $CFG_CC            = 'q(gcc)';                # substituted via
Makefile.tmpl
my $CFC_CFLAGS        = 'q( -DSOLARIS=260 -DMOD_PERL -DUSE_PERL_SSI
-I/usr/local/include -DUSE_EXPAT -I../lib/expat-lite `../apaci`)';
my $CFC_CFLAGS_SHLIB  = 'q(-fPIC -DSHARED_MODULE)';
my $CFG_LD_SHLIB      = 'q(ld)';
my $CFG_LDFLAGS_SHLIB = 'q(-G)';
my $CFG_LIBS_SHLIB    = 'q()';
my $CFG_PREFIX        = 'q(/usr/apache)';
my $CFG_SBINDIR       = 'q(/usr/apache/bin)';
my $CFG_INCLUDEDIR    = 'q(/usr/apache/include)';
my $CFG_LIBEXECDIR    = 'q(/usr/apache/libexec)';
my $CFG_SYSCONFDIR    = 'q(/usr/apache)';

When executing the script, I now receive the following errors:

	Global symbol "$CFG_FLAGS" requires explicit package name at
/usr/apache/bin/apxs line 91.
	Global symbol "$CFG_CFLAGS_SHLIB" requires explicit package name at
/usr/apache/bin line 371.

I was unable to copy verbatim the settings that John had mentioned due to
differences in the location of certain apache directories.
Does anyone have an idea why this is failing?



Mark Crouch
Web Application Developer
Voice: (616) 913-4103
Fax: (616) 456-5250
 <<...>> 


Mime
View raw message