tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mo be <osaft2...@yahoo.de>
Subject Building mod_jk for solaris
Date Mon, 07 May 2001 08:58:16 GMT
Hi! 

I'm trying to compile mod_jk.so under solaris 2.6 .

Using ./build-solaris.sh of jakarta-tomcat-3.3-m2 +
Apache/1.3.12 (Unix) I get only this weird msg
"Command failed with rc=..." from apxs.

java -version =
"Java(TM) 2 Runtime Environment, Standard Edition
(build 1.3.0)
Java HotSpot(TM) Client VM (build 1.3.0, mixed mode)"

I already tried to build mod_jk from the tomcat.3.2.1
sources, but I get the same error again and again.

Below you find the ouput of ./build-solaris.sh

Any ideas?

Regards
Mounir

Building mod_jk
gcc -DSOLARIS -DUSE_EXPAT -I../lib/expat-lite 
-I/usr/local/apache/include -I../common
-I/usr/j2se/include -I/usr/j2se/include/solaris  -c
../common/jk_ajp12_worker.c

[...]

gcc -DSOLARIS -DUSE_EXPAT -I../lib/expat-lite 
-I/usr/local/apache/include -I../common
-I/usr/j2se/include -I/usr/j2se/include/solaris  -c
mod_jk.c
  -o mod_jk.so mod_jk.o jk_worker.o jk_util.o
jk_uri_worker_map.o jk_sockbuf.o jk_pool.o jk_nwmain.o
jk_msg_buff.o jk_map.o jk_lb_worker.o jk_jni_worker.o
jk_connect.o jk_ajp13_worker.o jk_ajp13.o
jk_ajp12_worker.o -lposix4
apxs:Break: Command failed with rc=16711680
Error with apxs    

__________________________________________________________________
Do You Yahoo!?
Gesendet von Yahoo! Mail - http://mail.yahoo.de

Mime
View raw message