tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Gruber" <mgru...@net-west.com>
Subject Re: Tomcat Boot: Help!
Date Wed, 02 May 2001 14:52:23 GMT
My script:


---------------------------------------------------
#!/bin/sh
#
# Start/Stop Jakarta Tomcat

# Source function library
. /etc/rc.d/init.d/functions

export PATH=$PATH:/usr/java/jdk1.3.0_02/bin
export JAVA_HOME=/usr/java/jdk1.3.0_02
export TOMCAT_HOME=/usr/java/jakarta-tomcat-3.2.1

case "$1" in
  start)
    echo -n "Starting tomcat: "
    daemon "/usr/java/jakarta-tomcat-3.2.1/bin/tomcat start"
    echo
    touch /var/lock/subsys/tomcat
    ;;
  stop)
    echo -n "Shutting down tomcat: "
    daemon "/usr/java/jakarta-tomcat-3.2.1/bin/tomcat stop"
    echo
    rm -f /var/lock/subsys/tomcat
    rm -f /var/run/tomcat.pid
    ;;
  restart)
    $0 stop
    sleep 2
    $0 start
    ;;
  *)
    echo "Usage: $0 {start|stop|restart}"
    exit 1
esac

exit 0
---------------------------------------------------

I have used other scripts as well, some that use "su", some that just call
/usr/java/jakarta-tomcat-3.2.1/bin/tomcat.sh...none of them have worked.  I
get the same results every time.  Tomcat appears to start (from reading the
logs) but then mysteriously dies before I can run "ps aux".  The script is
currently in /etc/rc.d/init.d with symbolic links in the various rcx.d
directories pointing to it.  When I run the script from the command line, it
works properly, but not while the system is booting.  What distro are you
using, and what versions of Tomcat, Apache, JDK are you using, if you don't
mind me asking?


MGRUBER

----- Original Message -----
From: "Darrell Porter" <dporter@wiseconnect.com>
To: <tomcat-user@jakarta.apache.org>
Sent: Tuesday, May 01, 2001 6:38 PM
Subject: RE: Tomcat Boot: Help!


> What does your script look like?
>
> Where is it?
>
>
>
> -----Original Message-----
> From: Mike Gruber [mailto:mgruber@net-west.com]
> Sent: Tuesday, May 01, 2001 10:17 AM
> To: tomcat-user@jakarta.apache.org
> Subject: Tomcat Boot: Help!
>
>
> I am still desperately trying to get Tomcat 3.2.1 to start up at boot
time.
> It starts, but then dies before the login.  Running the exact same init
> script from the command line works no problem, so I am completely at a
loss
> as to the cause of the problem.  I am so desperate, I am even willing to
> completely change Linux distributions if anyone out there knows a distro
> that works with Tomcat.  I am currently using Caldera eServer 2.3 with
> jdk1.3.0_02 and apache 1.3.19.  Please reply to this post and tell me what
> distribution, versions, etc you are using to make tomcat load at boot
time.
> Any and all information will be greatly appreciated.
>
>
> MGRUBER
>


Mime
View raw message