tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "niv maman" <...@movious.com>
Subject Re: xalan ApplyXSL sample servlet fails
Date Tue, 29 May 2001 21:23:25 GMT
hi .
did u check it with the new release of tomcat 3.2.2?
----- Original Message ----- 
From: "Stan Devitt" <jsdevitt@stratumtek.com>
To: <tomcat-user@jakarta.apache.org>
Sent: Tuesday, May 29, 2001 5:29 PM
Subject: Re: xalan ApplyXSL sample servlet fails


> I got it (or rather, DefaultApplyXSLT) to work.  The resolution was:
> 
>         1.  Use xalan-j_2_0_0, and the servlet example
>         from there which uses ApplyXSLT 
> 
>         2.  Clean up my careless classpath usage of jar files leading
>         instead with xalan.jar and xerces.jar from the xalan2_0_0
>         distribution.
> 
>         3.  Be sure to get the right path to the servlet as the
>         new servlet example is now in a "servlet" package instead of 
>         the top level of the context.)
> 
>         (I am now using tomcat 3.2.1, together with jdk1.3.1,
> xerces 1.2.3 and xalan 2.0.0 on Windows 2000.)
> 
> Thanks.
> 
> Stan.
> 
> ----- Original Message ----- 
> From: "Chris McNeilly" <cmcneilly@smartbrief.com>
> To: <tomcat-user@jakarta.apache.org>
> Sent: Tuesday, May 29, 2001 8:46 AM
> Subject: RE: xalan ApplyXSL sample servlet fails
> 
> 
> > Funny you should ask.  I had (possibly) a very similar problem last
> > week.  After combing through maillists etc, I found a reference
> > suggesting that there was a conflict with the xerces xml parser and the
> > xml parser included with tomcat.  It suggested removing parser.jar and
> > jaxp.jar from the classpath in the tomcat startup scripts (tomcat.bat
> > for me).  That worked for me.  I've only been playing with it for a day
> > or two, but it doesn't seem to break tomcat and now my xalan-based
> > servlets function.
> > 
> > Chris
> > 
> 


Mime
View raw message