tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milt Epstein <mepst...@uiuc.edu>
Subject Session problem -- sessions being recreated, browser related?
Date Tue, 03 Apr 2001 20:06:37 GMT

On a servlet-based application I have, I'm getting sporadic reports of
problems from users.  The symptoms are similar to what happens when
cookies are disabled (but they aren't, because I had the users check).
Basically, they can't get past the front page of the application,
because it won't let them without a valid session (recall that session
access is handled via cookies -- I'm not using URL Rewriting).  And
each time they try, Tomcat is creating a new session for them (and
giving them a new cookie).  Apparently, it's not recognizing the
existing session.

Now, this is only happening to a small subset of the users.  I haven't
isolated a pattern yet, but it may only be happening from certain
machines.  And the couple of machines I have found the problem on so
far are both using Internet Explorer version 4.0.  So that might be a
factor.  (I don't have 4.0 myself, but I did find an old copy of 3.02,
and it works OK with that.)

Oh, a bit of background -- we switched over from using Netscape
Enterprise Server and ServletExec to Apache/Tomcat a couple of weeks
ago, and the problem seems to have only started occurring since then.
So it does appear to be something Apache/Tomcat-specific.

Thanks.

Milt Epstein
Research Programmer
Software/Systems Development Group
Computing and Communications Services Office (CCSO)
University of Illinois at Urbana-Champaign (UIUC)
mepstein@uiuc.edu


Mime
View raw message