tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milt Epstein <mepst...@uiuc.edu>
Subject Re: java.lang.UnsatisifedLinkError
Date Tue, 03 Apr 2001 14:03:04 GMT
On Tue, 3 Apr 2001 marco@convey.it wrote:

> hello,
> 
>         I found some talk of this in the archives but no solution was
> ever suggested and it's becoming a real problem for me. My code calls
> JNI functions, if i compile and build everything and then start up
> tomcat all my pages work, all the java classes behind them work and
> everybody's happy. The problem appears when i modify a java class and
> recompile it, the next time i visit a page (even one which doesn't
> call code which uses the JNI lib) i get this unsatisfied link error
> and a message about my .so already being loaded in another class
> loader. All of my .class get put in a jar which then gets put in my
> app's WEB-INF directory, i'm assuming that this is why i get the
> unsatisifed link error even if the page i try to view calls code which
> doesn't call the JNI lib, correct? Is this a mistake of mine or a bug?
> in the later case is there a work around? should i try with tomcat 4?
> 
> possibily useful info:
> jdk 1.3
> tomcat 3.2.1
> linux 2.4 

This sounds like a problem I ran into.  And I did post about it on the
list (including after I found the solution myself).  Here's the
relevant post from the archive:

http://marc.theaimsgroup.com/?l=tomcat-user&m=98383500924069&w=2

(Note that there are two archives of the list, one is found under
"Mailing List Archives" and one under "Tomcat-User Archives" on the
jakarta.apache.org page that lists the archives; the former has
archives for a ton of lists, including a bunch of apache-related ones,
and has a nicer interface.)

Milt Epstein
Research Programmer
Software/Systems Development Group
Computing and Communications Services Office (CCSO)
University of Illinois at Urbana-Champaign (UIUC)
mepstein@uiuc.edu


Mime
View raw message