tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kieran Barry <kba...@dragon.snaz.com>
Subject Re: problem with virtual hosting
Date Mon, 02 Apr 2001 21:22:40 GMT
On Mon, 2 Apr 2001, Christopher Shade wrote:

> I tried to map www.domain.com to www.domain.com/webapp by using
> ServerName and ServerAlias in the config file, but it's not working.
> Below is what I tried in my-tomcat-apache.conf.  What am I doing wrong?
> Is there a better way to map a domain to a webapp?  Thanks!
> ...Christopher
> 
> ####################### my-tomcat-apache.conf #############
> 
> LoadModule jserv_module libexec/mod_jserv.so
> ApJServManual on
> ApJServDefaultProtocol ajpv12
> ApJServSecretKey DISABLED
> ApJServMountCopy on
> ApJServLogLevel notice
>  
> ApJServDefaultPort 8010
> 
> # Name the Virtual Host IP
> NameVirtualHost ...server IP is here...
>  
> # Define the Virtual Hosts
> <VirtualHost ...server IP is here...>
>     ServerName www.domain.com/fas
>     ServerAlias www.domain.com
>     ApJServMount /fas ajpv12://www.domain.com:8010/fas
>     DocumentRoot /usr/local/apache/prod/htdocs/fas
> </VirtualHost>
> 
> AddType text/jsp .jsp
> AddHandler jserv-servlet .jsp
> 
> ...and the Alias entries for my webapps...
> 
> 
> 
Something to look at would be RedirectMatch or Redirect.

Stick in something like:

Redirect / http://www.domain.com/fas

in the Virtualhost.

Of course, I could be wrong.

regards

Kieran


Mime
View raw message