tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fox, the Balloon Fox" <tomcat-u...@balloonfox.com>
Subject RE: mod_webapp for win32, cygwin or VC++? ...or maybe a silver bullet?
Date Sat, 21 Apr 2001 16:55:41 GMT
OH!!  I totally forgot!

I'm using Tomcat 4 beta 1
apache 1.3.14 (though 1.3.19 didn't show me love either)
Windows 2000 Pro.


> -----Original Message-----
> From: Fox, the Balloon Fox [mailto:tomcat-user@balloonfox.com]
> Sent: Saturday, April 21, 2001 11:47 AM
> To: Tomcat-User@Jakarta. Apache. Org
> Subject: mod_webapp for win32, cygwin or VC++? ...or maybe a siver
> bullet?
> 
> 
> Hi all,
> 
> I'm currently trying to give tomcat 4 a go, but I keep getting gummed up
> when I try to get it working with apache 1.3.  I've tried compiling
> mod_webapp using cygwin, with I haven't had much luck.  I edit 
> the makefile
> with the correct path to apxs.pl, and edit the first line in apxs.pl to
> reflect the location of perl, but I end up getting this output:
> 
> make[1]: Entering directory
> `/home/administrator/jakarta-tomcat-4.0-b1/src/connectors/webapplib'
> make[1]: `libwebapp.a' is up to date.
> make[1]: Leaving directory
> `/home/administrator/jakarta-tomcat-4.0-b1/src/connectors/webapplib'
> make[1]: Entering directory
> `/home/administrator/jakarta-tomcat-4.0-b1/src/connectors/apache-1.3'
> /home/administrator/support/apxs.pl -c -I../webapplib 
> -L../webapplib -lwebap
> p mod_webapp.c
> make[1]: Leaving directory
> `/home/administrator/jakarta-tomcat-4.0-b1/src/connectors/apache-1.3'
> apxs:Error @sbindir@/@TARGET@ not found or not executable
> make[1]: *** [mod_webapp.so] Error 1
> make: *** [apache-1.3/mod_webapp.so] Error 2
> 
> I've tried just about everything I know, but I just can't get cygwin to
> compile it.  I guess my real question is, should I give up on 
> cygwin and get
> myself Microsoft Visual C++?
> 
> Also if you know what I'm doing wrong, that would be great too! ...I
> actually tired compiling it in BeOS.  I didn't get this problem 
> at all, so I
> just don't think it's anything I'M doing wrong...i hope
> 
> Thankies!
> Fox, the Balloon Fox
> 
> 


Mime
View raw message