tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Taylor, Richard" <Richard.Tay...@bskyb.com>
Subject RE: WEB-INF/lib vs. TOMCAT_HOME/lib
Date Wed, 18 Apr 2001 10:18:14 GMT
I have the same problem and have posted the same thing before with no reply.
I actually keep the jars in the WEB-INF/lib directory and add them to the
Tomcat classpath with wrapper.properties (I'm starting as an NT service).
This means a config change whenever I deploy a webapp which is far from
ideal.

Maybe someone with superior knowledge about this could shed some light this
time?

Richard.

-----Original Message-----
From: Chris Bailey [mailto:chrisb@wego.com]
Sent: Tuesday, April 17, 2001 7:32 PM
To: tomcat-user@jakarta.apache.org
Subject: WEB-INF/lib vs. TOMCAT_HOME/lib


The Tomcat automatic setting of a classpath for a given webapp is not
seeming to work for me.  I have my various jar files in .../WEB-INF/lib,
for my web app.  But, that fails.  If I however, put them in
$TOMCAT_HOME/lib, then they get added to the generic classpath (which is
displayed on startup of Tomcat), and things work fine.  

How do I fix this?

-- 
Chris Bailey            chrisb@wego.com
Wego Systems            http://www.wego.com


**********************************************************************
Information in this email is confidential and may be privileged. 
It is intended for the addressee only. If you have received it in error,
please notify the sender immediately and delete it from your system. 
You should not otherwise copy it, retransmit it or use or disclose its
contents to anyone. 
Thank you for your co-operation.
**********************************************************************

Mime
View raw message