tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Altuğ Altıntaş (Koç.Net) <alt...@koc.net>
Subject RE: TOMCAT and APACHE
Date Fri, 27 Apr 2001 14:25:59 GMT
Did u enable  mod_so module for your apache ? 


-----Original Message-----
From: java.harjes@gmx.de [mailto:java.harjes@gmx.de]
Sent: Friday, April 27, 2001 5:18 PM
To: tomcat-user@jakarta.apache.org
Subject: TOMCAT and APACHE


Hi experts,

I have some problems in integrating TOMCAT and APACHE like it is described
in your "Minimalistic User's Guide".

My Apache Webserver Version 1.3.14-6 is running on a SUSE 7.1 - LINUX
machine and it works fine for itself.
The Tomcat Version is 3.1-70 and also this application works fine as a
stand-alone server, i.e. I get contact to the servlets via the 8080 port.

Now I tried to integrate both components:

  (1) I appended the /conf/tomcat-apache.conf to the httpd.conf

       A restart of the httpd failed, the error log said that the
mod_jserv.so couldn't be found in the directory: /usr/local/httpd/libexec

       There was indeed no such directory!?
  (2) So I created it and copied the existing mod_jserv.so - file from the
directory /usr/lib/apache to /usr/local/httpd/libexec

       A restart of the httpd was now successfull but the apache webserver
didn't answer on requests !?
       The error-log file said:

       [Fri Apr 20 19:14:02 2001] [emerg] JServ: Error setting defaults:
ApJServLogFile: file '/usr/local/httpd/./logs/mod_jserv.log' can't be opened
       [Fri Apr 20 19:14:02 2001] [crit] (2)No such file or directory:
Apache JServ encountered a fatal error; check your ApJServLogFile for
details if none are present in this file.  Exiting.

  (3) Following chapter "Obtaining the Jserv Module" in your "Minimalistic
User's Guide"  I downloaded the tomcat source jakarta-tomcat-3.1.1-src
       and executed the build command     apxs -c -o mod_jserv.so *.c.

       The building of mod_jserv.so was no problem and successfully.

       Then I copied the new mod_jserv.so - file to /usr/local/httpd/libexec

       A restart of the httpd was again successfull but the apache webserver
didn't answer on requests again!?
       The error-log file said the same:

       [Fri Apr 20 19:14:02 2001] [emerg] JServ: Error setting defaults:
ApJServLogFile: file '/usr/local/httpd/./logs/mod_jserv.log' can't be opened
       [Fri Apr 20 19:14:02 2001] [crit] (2)No such file or directory:
Apache JServ encountered a fatal error; check your ApJServLogFile for
details if none are present in this file.  Exiting.



What shall I do?
I hope you can help me


Thanks a lot
J. Harjes


-- 
GMX - Die Kommunikationsplattform im Internet.
http://www.gmx.net

Mime
View raw message