tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Novotny <JDNovo...@lbl.gov>
Subject Re: setAttribute/getAttribute problem
Date Thu, 26 Apr 2001 19:04:45 GMT

    I stumbled into the same problem yesterday without any luck. Apparently
using request.set/getAtttribute is pretty much useless in my experience. I
had to stick the data in the session instead using session.set/getAttribute.
Not a very attractive solution, but it works anyway.

    Jason

Aaron Lindsey wrote:

> I'm having problems attaching an object to the request object in a servlet
> and pulling that object out again after forwarding to a jsp.  I've created
> a bean called PopBean that I attach to the request.  After forwarding to a
> jsp, I attempt to retrieve it from the request object and cast back to
> PopBean. I get a ClassCastException.  If I run a getClass().getName() the
> result is PopBean.  However, instanceof returns false when compared to
> PopBean.   I can create new instances of PopBean in the jsp with no
> problem.  I also can pass any of the standard java classes like Vector,
> String, etc. and pull them out with no problem.  This problem only happens
> with classes that I have created myself.
>    Does anyone have any ideas? I've been wrestling with this for a while
> without success.  BTW, I'm using Tomcat 3.2.1 on Solaris.  Thanks.
>
> Aaron

--
Jason Novotny               novotny@george.lbl.gov
Home: (510) 610-8360        Work: (510) 486-8662
NERSC Distributed Computing http://www-didc.lbl.gov




Mime
View raw message