tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anne Dirkse" <aldir...@uswest.net>
Subject Tomcat on Solaris
Date Fri, 06 Apr 2001 23:07:30 GMT
Hi All --

I'm trying to install Tomcat on Solaris 8 (sparc) and am running into
problems.

I'm running Tomcat 3.2.1, with java 1.2.2:
java version "1.2.2"
Solaris VM (build Solaris_JDK_1.2.2_06, native threads, sunwjit)

I have tomcat installed and running happily (more or less) on an
identical (or so I thought!) machine.

First I tried installing from a newly downloaded .tar.gz and got the
following exception:
 
Exception in thread "main" java.lang.ExceptionInInitializerError:
java.util.Mi
ssingResourceException: Can't find resource for base name
org.apache.tomcat.reso
urces.LocalStrings, locale en
        at java.lang.Throwable.fillInStackTrace(Native Method)
        at java.lang.Throwable.<init>(Throwable.java:94)
        at java.lang.Exception.<init>(Exception.java:42)
        at java.lang.RuntimeException.<init>(RuntimeException.java:47)
        at
java.util.MissingResourceException.<init>(MissingResourceException.java:54)
        at java.util.ResourceBundle.getBundle(Compiled Code)
        at java.util.ResourceBundle.getBundle(ResourceBundle.java:339)
        at
org.apache.tomcat.util.StringManager.<init>(StringManager.java:115)
        at
org.apache.tomcat.util.StringManager.getManager(StringManager.java:260)
        at <Unloaded Method>

Given that, tried tarring up my working tomcat from the other solaris
box and moving it over, and got the same exception.

All of my environment settings between the two Solaris machines *should*
be identical.
In fact, the machine that does work was, two weeks ago, an exact copy of
the one that is failing...

Has anyone run into something similar before? If so, I'd be thrilled to
hear a fix.

Thanks,

Anne
aldirkse@uswest.net

Mime
View raw message