tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hossein Tahani <tah...@cs.nmhu.edu>
Subject Re: NoClassDefFoundError
Date Wed, 04 Apr 2001 02:57:09 GMT

I get 
JAVACMD is /usr/jdk1.3/bin/java

Apparently, it doesn't find the
/usr/jdk1.3/lib/tools.jar that has the
sun.tools.javac.Main. But, tools.jar is in its
classpath.

Thanks!

Warren Crossing wrote:
> 
> hey it sounds like your tomcat is using the jre not the jdk! check the
> JAVA_HOME value tomcat startup up script is using by putting an echo command
> in the script..
> 
> -----Original Message-----
> From: Hossein Tahani [mailto:tahani@cs.nmhu.edu]
> Sent: Wednesday, 4 April 2001 12:08 PM
> To: tomcat users
> Subject: NoClassDefFoundError
> 
> Hi all,
> I just joined this list. If my question has been
> answered before I would appreciate a link to the
> answer.
> 
> I have installed jakarta-tomcat3.2.1 on red hat 7.0. I
> have integrated with apache1.3.19 with mod_jserv.
> 
> I have no problem with servlets, but when I access some
> of the .jsp files I get the following error message:
> Root cause:
> 
> java.lang.NoClassDefFoundError: sun/tools/javac/Main
>         at
> org.apache.jasper.compiler.SunJavaCompiler.compile(SunJavaCompiler.java:128)
>         at
> org.apache.jasper.compiler.Compiler.compile(Compiler.java:285)
>         at
> org.apache.jasper.servlet.JspServlet.doLoadJSP(JspServlet.java:478)
>         at
> org.apache.jasper.servlet.JasperLoader12.loadJSP(JasperLoader12.java:146)
>         at
> org.apache.jasper.servlet.JspServlet.loadJSP(JspServlet.java:449)
>                       ...
>                       ...
>                       ...
> 
> Any idea is greatly appreciated.
> 
> Hossein
> 
> --
> Hossein Tahani, Ph.D.    505-454-3301
> Highlands University

-- 
Hossein Tahani, Ph.D.    505-454-3301
Highlands University

Mime
View raw message