tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "patricklee99" <patrickle...@sinaman.com>
Subject RE: Preload Servlet in Tomcat
Date Thu, 26 Apr 2001 16:05:18 GMT

> a) What error do you get?

It is the error message.

Internal Servlet Error:

javax.servlet.ServletException
	at org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:459)
	at _0002fuser_0005flist_0002ejspuser_0005flist_jsp_0._jspService(_0002fuser_0005flist_0002ejspuser_0005flist_jsp_0.java:150)
	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:119)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at org.apache.jasper.servlet.JspServlet$JspServletWrapper.service(JspServlet.java:177)
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:318)
	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:391)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at org.apache.tomcat.core.ServletWrapper.doService(ServletWrapper.java:404)
	at org.apache.tomcat.core.Handler.service(Handler.java:286)
	at org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
	at org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:797)
	at org.apache.tomcat.core.ContextManager.service(ContextManager.java:743)
	at org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:210)
	at org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)
	at org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:498)
	at java.lang.Thread.run(Thread.java:484)

Root cause: 
java.lang.NullPointerException
	at _0002fuser_0005flist_0002ejspuser_0005flist_jsp_0._jspService(_0002fuser_0005flist_0002ejspuser_0005flist_jsp_0.java:73)
	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:119)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at org.apache.jasper.servlet.JspServlet$JspServletWrapper.service(JspServlet.java:177)
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:318)
	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:391)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at org.apache.tomcat.core.ServletWrapper.doService(ServletWrapper.java:404)
	at org.apache.tomcat.core.Handler.service(Handler.java:286)
	at org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
	at org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:797)
	at org.apache.tomcat.core.ContextManager.service(ContextManager.java:743)
	at org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:210)
	at org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)
	at org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:498)
	at java.lang.Thread.run(Thread.java:484)

And it is the same problem that I did not add the line for the preload servlet in the web.xml.
So I don't know is that any error on the line that I add to the web.xml. Since the applcation
is running on the Jrun with no problem and I only change the environment from Jrun to tomcat.
And tomcat and Jrun seems to be the same to be the servlet engine. So I think there is the
problem of the setting. But I still do not where is the problem come from.

Thanks for your help.


> b) Do you get the same error when you start the servlet manually (by
> connecting with a browser)?


>                                                             -- Bill
> K.


> -----Original Message-----
> From: patricklee99 [mailto:patricklee99@sinaman.com]
> Sent: Thursday, April 26, 2001 2:40 AM
> To: tomcat-user@jakarta.apache.org
> Subject: Preload Servlet in Tomcat
>
>
>
> Hello,
>
> I am just develop a application in Jrun and I am trying to
> run it on tomcat 3.2.1 (Both for web server and servlet
> engine) on win2k. And I want to preload a servlet when the
> tomcat start.
>
> I add some line in the file <TOMCAT_HOME>/conf/web.xml
like that
>
>     <servlet>
>         <servlet-name>
>             ContentServletNT
>         </servlet-name>
>         <servlet-class>
>             com.i2.iba.test.ContentServletNT
>         </servlet-class>
> 	<load-on-startup>
>             1
> 	</load-on-startup>
>     </servlet>
>
> But after I restart the server, it seems not work. It display
> a error with the same as without this line. Is there any
> problem with this few line?
>
> And I am also cannot login the admin page of the tomcat. What
> is the username and password for the tomcat admin page?
>
> Thanks for your help.
>
> Regards,
>
> Patrick Lee
>
>
==================================================================
> ·s&reg;&ouml;§K&para;O&sup1;q&curren;l&laquo;H&frac12;c
 http://sinamail.sina.com.hk
>
>
>

==================================================================
新浪免費電子信箱  http://sinamail.sina.com.hk




Mime
View raw message