tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Kilbride" <>
Subject Re: Is corrupt?
Date Tue, 24 Apr 2001 01:11:41 GMT
Hi John,

Yes, several people have had problems. The easiest course of action is to
download the Tomcat sources and compile your own It's pretty
straightforward. After you download the source, cd to the top level source
directory. Then do the following:

cd /src/native/apache1.3  (assuming you're using 1.3.x)
cp Makefile.linux Makefile

It took about 2 minutes to compile on my machine Then copy the new
to your apache libexec/ directory. This worked for me.


----- Original Message -----
From: "John Hebert" <>
To: <>
Sent: Monday, April 23, 2001 5:50 PM
Subject: Is corrupt?

> I believe that the file
> might be corrupt. I didn't think so at first and suspected that it was
something I was doing wrong,
> but I've downloaded the file a few times and would only get the error:
> [root@webserver bin]# ./apachectl start
> Syntax error on line 8 of /usr/local/tomcat/conf/mod_jk.conf-auto:
> API module structure `jk_module' in file
/usr/local/apache/libexec/ is garbled - perhaps this is not an
Apache module DSO?
> ./apachectl start: httpd could not be started
> I saw Henri Gomez's announcement about the Tomcat v3.2.2-beta-3 version
being available as well as the
/, so I
> tried that instead and httpd started.
> Has anybody else had problems getting
> to work?
> --
> John Hebert
> System Engineer
> Changing your state of mind through sound.

View raw message