tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jae H. Roh" <jh...@alum.mit.edu>
Subject Re: ERROR WITH mod_jk.so module
Date Mon, 09 Apr 2001 22:59:30 GMT
I got the same error message, simply trying to load the linux binary
mod_jk.so from the jakarta.apache.org site.  I'm not sure what version of
linux that was compiled for, but it didn't work for me either.

What worked for me is to recompile the mod_jk using the source distribution
jakarta-tomcat-3.2.1-src.  A couple of notes:
1.  go to the subdirectory src/native/apache1.3
2.  copy Makefile.linux to Makefile, then edit it with the right paths for
JAVA_HOME and APXS (should be in ../apache/bin)
3.  even when it runs, it errors out, so run this
gcc -shared -o mod_jk.so *.o
to finish the build

If that doesn't work for you, mail me directly, and I can mail you a copy of
the mod_jk that I built.

See
http://jakarta.apache.org/tomcat/jakarta-tomcat/src/doc/mod_jk-howto.html#s6
2  for more details on configuring mod_jk and tomcat...

- jae


----- Original Message -----
From: "Ruben Domene" <rdomene@svalero.es>
To: <tomcat-user@jakarta.apache.org>
Sent: Monday, April 09, 2001 6:01 PM
Subject: ERROR WITH mod_jk.so module


I have Red Hat 6.2 with Apache 1.3.14 and Tomcat 3.2.1.
In the httpd.conf file i add the follow line: "Include
/usr/programas/jakarta-tomcat-3.2.1/conf/mod_jk.conf-auto". When i execute
"apachectl start" and then show me the next message:
"Syntax error on line 9 of
/usr/programas/jakarta-tomcat-3.2.1/conf/mod_jk.conf-auto:
API module structure `jk_module' in file /usr/local/apache/libexec/mod_jk.so
is garbled - perhaps this is not an Apache  module DSO?"

What is the problem??
Thank you for your help and excuse me by my english.



Mime
View raw message