tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Kilbride" <j...@kilbride.com>
Subject Re: Problem with mod_jk build
Date Fri, 06 Apr 2001 22:31:20 GMT
Hi Brandon,

First of all, did you download the *source* distribution for Jakarta? In
order to compile your own mod_jk.so, you need the source distribution --
jakarta-tomcat-3.2.1-src.tar.gz.

When you have the source untarred, cd into the source directory and then to:

src/native/apache1.3/

In there you will find Makefiles for different systems. Rename the correct
one for your system from Makefile.system to just Makefile. Then run the
command 'make' in that directory. If everything is ok, mod-jk.so will be
made for you in that directory. Copy it to your apache/libexec and update
your httpd.conf (or include mod_jk.conf into your httpd.conf...)

It's pretty easy and it worked for me the first time.

Thanks,
--jeff

----- Original Message -----
From: "Brandon Cruz" <bcruz@norvax.com>
To: <tomcat-user@jakarta.apache.org>
Sent: Friday, April 06, 2001 5:11 PM
Subject: RE: Problem with mod_jk build


>
> I really need some help quick!!!  When it is telling me to use this
command
> to build mod_jk...
>
> apxs -o
>
mod_jk.so -I../jk -I/usr/local/jdk/include -I/usr/local/jdk/include/linux -c
> *.c ../jk/*.c
>
> Does that mean that I need to substitute something in for the *.c?  It
keeps
> telling me that  gcc: *.c no such file or directory
>
> If anyone knows what is going on, please help, I am very frustrated with
> this, have been working on it for 2 days.
>
> Thank you!
>
> Brandon Cruz
>
> -----Original Message-----
> From: Brandon Cruz [mailto:bcruz@norvax.com]
> Sent: Friday, April 06, 2001 4:39 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Problem with mod_jk build
>
>
>
>
>
> Quick question...
> If I have a binary version of mod_jk.so, do I have to build it?  It said
it
> is already built for Linux, but I can't get apache to start when I put
that
> into apache's libexec directory and include the mod_jk.conf-auto.  What am
I
> doing wrong?  I have tried to build mod_jk, but get all kinds of errors
> telling me that files do not exist.
>
> Brandon Cruz
>
>
>


Mime
View raw message