tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Kofon" <pko...@hotmail.com>
Subject RE: JDBC + Tomcat NT Service
Date Thu, 01 Jan 1970 00:00:00 GMT
Hi Randy,
Thanks! I'm sorry I failed to mention that I had put the jar files in the 
lib directory as well. I don't have a problem loading the drivers when I run 
Tomcat normally but I do when I run it as a service - the drivers just 
refuse to load. The JDBC drivers are not the only jars in the lib directory. 
I've got some other jars that I have no problems using even while running 
Tomcat as a Win2K service.
I guess someone has got to check this out. It's strange, but who knows I 
just might be doing something wrong.

Regards,

Paul

>From: Randy Layman <randy.layman@aswethink.com>
>Reply-To: tomcat-user@jakarta.apache.org
>To: tomcat-user@jakarta.apache.org
>Subject: RE: JDBC + Tomcat NT Service
>Date: Mon, 26 Mar 2001 08:20:16 -0500
>
>
>	I always put the drivers into the web app's lib folder and don't
>have any problem - Tomcat loads them automatically (if they are .jar files)
>and this way you can replace the drivers for one webapp at a time without
>affecting the other webapps (this is useful when you are converting several
>webapps on a machine - you can rollout the changes one webapp at a time)
>
>	Things to check -
>	1.  Path to drivers is actually correct and doesn't contain any
>spaces
>	2.  Permissions on the JAR file and directory's above (this only
>applies if you have changed NT's defaults.  By default Everyone can do
>anything with any file or directory).
>
>	Randy
>
>

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.


Mime
View raw message