tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chandra Goliva <chand...@gene.com>
Subject Re: CLASSPATH and Load-on-startup related issue - bug ??
Date Thu, 01 Mar 2001 02:57:52 GMT
I too noticed this problem.The Tomcat is recognizing the WAR files/ web
appl. directory structure autmatically from TOMCAT_HOME/webapps but the
archieves or libraries that are put in WEB-INF/lib are not being picked
up dynamically.
That's the reason why I am just keeping all the reqd. libraries into
/lib
under TOMCAT_HOME.
I appreciate any comments/response on this.
-Chandra
Anuj Agrawal wrote:

> Actually, i believe tomcat does pick up the jars from the WEB-INF/lib
> directory.  You might want to try looking in the jasper.log file in
> the logs directory.  It should show something like:
>
> Classpath according to the Servlet Engine is:
> <list of jar files in WEB-INF/lib dir>
>
> I'm using tomcat 3.2.1 - not sure if that makes a diff.  Originally i
> thought i needed to add the jar files to classpath via the
> wrapper.properties file, but then i found that i didn't need to.
>
> Hope that helps.
> Anuj.
>
> Srinivas Kurella wrote:
>
>> i am reposting this. I didn't get any responses. Does anybody have
>> an answer ?? Thanks in advance.Srini
>>
>>      -----Original Message-----
>>      From: Srinivas Kurella
>>      Sent: Wednesday, February 28, 2001 1:04 PM
>>      To: 'tomcat-user@jakarta.apache.org'
>>      Subject: RE: CLASSPATH and Load-on-startup related issue -
>>      bug ??
>>      Actually , it looks as if tomcat doesn't pick up the jars
>>      from the web-inf/lib directory. Once i added the jars
>>      explicitly to the classpath is worked. Is this a bug ???
>>
>>      Srini
>>
>>      -----Original Message-----
>>      From: Srinivas Kurella
>>      Sent: Wednesday, February 28, 2001 12:32 PM
>>      To: 'tomcat-user@jakarta.apache.org'
>>      Subject: CLASSPATH and Load-on-startup related issue ??
>>
>>
>>      I have an application which is running under tomcat.
>>      However i donot use the
>>      2.2 spec directory structure. I have a servlet that is
>>      loaded on startup. I
>>      explicitly set the CLASSPATH with all the jars needed.
>>      I am trying to move to the webapps/ directory structure
>>      where i can put all
>>      the jars under WEB-INF/lib.
>>      However the startup servlet fails with some class not
>>      found exception. Is
>>      the CLASSPATH variable ignored in this case ?? What could
>>      be the problem ??
>>      The startup servlet is a class in a jar in WEB-INF/lib.
>>
>>      Thanks
>>
>>      Srini
>>
>>
>>      --------------------------------------------------------------------
>>
>>      To unsubscribe, e-mail:
>>      tomcat-user-unsubscribe@jakarta.apache.org
>>      For additional commands, email:
>>      tomcat-user-help@jakarta.apache.org
>>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org For
> additional commands, email: tomcat-user-help@jakarta.apache.org

Mime
View raw message