tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Akers" <ak...@cc.admin.unt.edu>
Subject Re: Help with Tomcat 3.2 under Netscape NES 3.6
Date Thu, 01 Feb 2001 13:48:00 GMT
I got this working successfully a while back and as I recall had to go
in and get rid of all references to ajp13 in order to get those two to
coexist.  Good luck!

               Allen Akers
               Programmer Analyst
               Strategic Web and Voice Development
               ________________________________
               akers@cc.admin.unt.edu


>>> dtarrant@optimise.com.au 01/30/01 06:47PM >>>
   Hi, I am having trouble getting Tomcat 3.2 working under Netscape
Enterprise Server 3.6 running on a NT4 workstation. Any help would be
great

Although we have been using Tomcat under Apache, a client wishes it to
run under NES, which we know nothing about.

I configured the OBJ.CONF file as sugested.
Init funcs="jk_init,jk_service"
shlib="D:/apps/ApacheGroup/jakarta/tomcat/bin/win32/i386/nsapi_redirect.dll"
fn="load-modules"
Init fn="jk_init"
worker_file="D:/apps/ApacheGroup/jakarta/tomcat/conf/workers.properties"
log_level="debug"
log_file="D:/apps/ApacheGroup/jakarta/tomcat/logs/netscape_redirect.log"

<Object name="default">
#NameTrans fn="assign-name" from="/servlet/*" name="servlet"
NameTrans fn="assign-name" from="/servlet/SnoopServlet" name="servlet"
PathCheck fn="deny-existence" path="*/WEB-INF/*"
</Object>

<Object name="servlet">
ObjectType fn="force-type" type="text/html"
Service fn="jk_service" worker="ajp12"
</Object>

Tomcat starts up fine with the following in the concole

2001-01-31 11:33:58 - ContextManager: Adding context Ctx( /examples )
2001-01-31 11:33:58 - ContextManager: Adding context Ctx( /admin )
Starting tomcat. Check logs/tomcat.log for error messages
2001-01-31 11:33:58 - ContextManager: Adding context Ctx(  )
2001-01-31 11:33:58 - ContextManager: Adding context Ctx( /test )
2001-01-31 11:33:59 - PoolTcpConnector: Starting HttpConnectionHandler
on 8080
2001-01-31 11:33:59 - PoolTcpConnector: Starting Ajp12ConnectionHandler
on 8007

and when we start up NES the netscape_redirect.log file contains the
following

[jk_worker.c (82)]: Into wc_open
[jk_worker.c (207)]: Into build_worker_map, creating 2 workers
[jk_worker.c (213)]: build_worker_map, creating worker ajp12
[jk_worker.c (138)]: Into wc_create_worker
[jk_worker.c (152)]: wc_create_worker, about to create instance ajp12
of ajp12
[jk_ajp12_worker.c (264)]: Into ajp12_worker_factory
[jk_worker.c (161)]: wc_create_worker, about to validate and init
ajp12
[jk_ajp12_worker.c (182)]: Into jk_worker_t::validate
[jk_ajp12_worker.c (194)]: In jk_worker_t::validate for worker ajp12
contact is localhost:8007
[jk_worker.c (177)]: wc_create_worker, done
[jk_worker.c (223)]: build_worker_map, removing old ajp12 worker 
[jk_worker.c (213)]: build_worker_map, creating worker ajp13
[jk_worker.c (138)]: Into wc_create_worker
[jk_worker.c (152)]: wc_create_worker, about to create instance ajp13
of ajp13
[jk_ajp13_worker.c (708)]: Into ajp23_worker_factory
[jk_worker.c (161)]: wc_create_worker, about to validate and init
ajp13
[jk_ajp13_worker.c (383)]: Into jk_worker_t::validate
[jk_ajp13_worker.c (396)]: In jk_worker_t::validate for worker ajp13
contact is localhost:8009
[jk_ajp13_worker.c (422)]: Into jk_worker_t::init
[jk_worker.c (177)]: wc_create_worker, done
[jk_worker.c (223)]: build_worker_map, removing old ajp13 worker 
[jk_worker.c (235)]: build_worker_map, done
[jk_worker.c (102)]: wc_open, done
[jk_nsapi_plugin.c (287)]: jk_init, a second passed

so it looks like NES knows about the redirector. But when I send a
request for the SnoopSerlvet as shown here from the NES access file:
127.0.0.1 - - [31/Jan/2001:11:36:44 +1100] "GET /servlet/SnoopSerlvet
HTTP/1.1" 404 207

the NES error file contains the following:
[31/Jan/2001:11:35:12] info (  261): successful server startup
[31/Jan/2001:11:35:12] info (  261): Netscape-Enterprise/3.6 SP3
B99.280.0054
[31/Jan/2001:11:35:13] verbose (  261): dstats: Using slotbase = 0
start = 0 end = 1024 last = 0 slots 
[31/Jan/2001:11:36:45] warning (  261): for host 127.0.0.1 trying to
GET /servlet/SnoopSerlvet, send-file reports: can't find
d:/apps/Netscape/SuiteSpot/docs/servlet/SnoopSerlvet (File Not Found
Error)

Which leads me to believe that the request is not getting passed to the
redirector. Could anyone help with this problem?

David Tarrant

Mime
View raw message