tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Aras" <st...@stevearas.com>
Subject Sorry no subj: ClassNotFoundError
Date Fri, 09 Feb 2001 02:09:43 GMT
When I try to run build.sh I get the error below.  Originally, I had the jdk
in a dir /usr/local/j2sdk1.3 but I noticed the build script was looking for
it in /usr/local/jdk/j2sdk1.3  I didn't want to chance changing the path to
/usr/local/j2sdk1.3  so I just copied the whole dir into
/usr/local/jdk/j2sdk1.3  and changed JAVA_HOME and the CLASSPATH.  The error
is confusing because my apps in Forte still work perfectly so that path must
be good (right?)  Ya got me.  I think I'll get a tattoo on my forehead that
says "Clueless".  Any help appreciated.

OS:  RH6.2

postgres@localhost sample]$ ./build.sh
This is JAVA_HOME
/usr/local/jdk/j2sdk1.3
This is CLASSPATH
.:/usr/local/jdk/j2sdk1.3/lib/classes.zip:/usr/lib/pgsql/jdbc7.0-1.2.jar:/us
r/local/jdk/j2sdk1.3/lib/tools.jar
This is CP
/usr/local/jakarta-tomcat-3.2.1/lib/ant.jar:/usr/local/jakarta-tomcat-3.2.1/
lib/servlet.jar:/usr/local/jakarta-tomcat-3.2.1/lib/jaxp.jar:/usr/local/jaka
rta-tomcat-3.2.1/lib/parser.jar:/usr/local/jdk/j2sdk1.3/lib/tools.jar
Couldn't find or load essential class `java/lang/Object'
java.lang.NoClassDefFoundError java/lang/Object


Lastly, I'm really really lost here.  I don't even know if this is what I
should be trying at all.  My goal is to get something working.  I'll be able
to move on but right now I don't even know if TomCat is running.  I do use
TomCat startup scripts provided.  I feel like a moron.  Hopefully, soon I
won't.


Mime
View raw message