tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eoin McCarthy <E...@INTAPP.co.uk>
Subject RE: Solaris 8, apache and mod_jk - problem with jsps and servlets
Date Mon, 19 Feb 2001 13:26:24 GMT

Hi, 

Got this working, more by accident than anything else. 

Load mod_alias BEFORE mod_jk. Servlets and jsps then work fine.

Reverse this and servlets can't be found and jsps are served as code. 


Eoin


-----Original Message-----
From: Eoin McCarthy 
Sent: Monday, February 05, 2001 11:50 AM
To: 'tomcat-user@jakarta.apache.org'
Subject: RE: Solaris 8, apache and mod_jk - problem



Hi, 

Just tried this. Unfortunately, it didn't work - java/lib/tools.jar was
already on the classpath
on startup and copying it to $TOMCAT_HOME/lib didn't have any effect. 

Thanks,
EOin

-----Original Message-----
From: Thomas Bezdicek [mailto:t.bezdicek@lgsoft.at]
Sent: Monday, February 05, 2001 11:13 AM
To: tomcat-user@jakarta.apache.org
Subject: AW: Solaris 8, apache and mod_jk - problem


Hi,

We had the same problem and solved it by copying the tools.jar into
$TOMCAT_HOME/lib.

BTW: dont use the Hotspot-Engine with -server Parameter it would
crash at sometime with signal 11, it is a bug, use -client Parameter.

regards, tom


-----Ursprngliche Nachricht-----
Von: Eoin McCarthy [mailto:Eoin@INTAPP.co.uk]
Gesendet: Montag, 05. Februar 2001 11:56
An: 'tomcat-user@jakarta.apache.org'
Betreff: Solaris 8, apache and mod_jk - problem




Hi,

I'm trying to configure apache 1.3.9  and tomcat 3.2 with mod_jk under
Solaris 8.  I'm using the example contexts supplied with the
tomcat.

A standalone configuration of tomcat serves the contexts OK as does tomcat
with apache using mod_jserv. However, I
can't get jsps to run using mod_jk - when I try to run one I just get the
source code. Servlets are also problematic:
for the provided webapps/examples context, the servlets run OK if I do not
explicitly specify that context in the server.xml file.
If I specify it, tomcat complains that it can't find the file (and yes, I
have the location right).

I suspect that the workers.properties file is the problem seeing as I'm
following the off-the-shelf configurations for
tomcat. However, the provided workers.properties file refers to DLLs,
indicating a win32 setup. I've set the paths required as per
my system but I may be missing something - the output from the mod_jk logs
seems to indicate that mod_jk can't find a worker for
jsps. I've tried both ajp12 and ajp13.

The configuration files I'm using are attached.

Any help would be greatly appreciated.
Eoin McCarthy


 <<tomcat-jk-2.conf>>


 <<workers.properties>>


 <<httpd.conf>>


 <<server.xml>>






---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, email: tomcat-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, email: tomcat-user-help@jakarta.apache.org

Mime
View raw message