tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "EXT-Mezey, Peter" <Peter.Me...@PSS.Boeing.com>
Subject Deadlock problem
Date Tue, 06 Feb 2001 21:58:25 GMT
I have tomcat 3.2.1 with Apache 1.3.12 running on a Solaris (2.6) box.  Everything works just
fine for normal use.  However, when I crank up a Verity search engine (vspider) to walk through
a document bundle of about 4,500 JSP pages I start to run into trouble.  Since every document
in the bundle is a JSP page, the vspider program is generating a considerable load on the
Apache/Tomcat installation.  After quite a bit of successful activity (say about a half hour
or more of processing), everything seems to just freeze up.  Looking at top, you can see that
the system is at a 100% iowait state.  Prior to that happening, you can see the tomcat process
slowly allocating more and more memory as it digests all the requests.  When it gets to about
200MB, that's when the system goes into 100% iowait state and tomcat basically stops.

I have increased the memory to tomcat via -Xms and -Xmx flags to 1GB.  I know it's not running
out of memory because I don't see that error message.  I've tried tinkering with the PoolTcpConnector
settings in server.xml to increase the number of threads to 200.  That seemed to make it run
faster, but still the deadlock problem.  One bit of confusion here is the tomcat.properties
file.  It has a "pool=false" setting in there along with a comment that says the Thread pooling
may cause deadlock problems.  I tried it with both true and false settings here, but to no
avail.  Oh, one other piece of information: I'm using the J2SDK 1.3.0.  Any help, hints or
pointers would be greatly appreciated.

thanks,

peter


Mime
View raw message