tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nael Mohammad <>
Subject RE: still having some trouble with mod_jk on SGI
Date Wed, 07 Feb 2001 19:24:08 GMT
Use mod_jserv, I've fought this battle and determined that mod_jk does not
work and mod_jserv works perfectly fine with Apache, tomcat and cocoon. All
working. With Mod_jk, never worked. 

-----Original Message-----
From: Hladky, David []
Sent: Wednesday, February 07, 2001 11:16 AM
To: ''
Cc: ''
Subject: still having some trouble with mod_jk on SGI

Mike and Others,
	Thanks for the info this morning on building it locally.  That
appears to have gotten me going in the right direction. I doesn't error
code rc=1 now.  I am still not getting it compile the shared object though.
As far as the libraries I jsut simply took my old apache
	and re-named it to old.  Question though?  Could I build mod_jk when
I compile apache rather than waiting until after it is built.  If 	so,
where would I place the jk source and libraries?  Probably can't but, just a

	Anyway, if anybody can help.  I hae the text of the output I am
getting so that someone who knows more than me can have a peak.

	indigo% /usr/local/apache/bin/apxs -o -DIRIX -I../jk
-I/usr/java/include -I/usr/java/include/irix -c *.c ../jk/*.c
	cc -DIRIX -n32 -DUSE_HSREGEX -DUSE_EXPAT -I../lib/expat-lite -KPIC
-DSHARED_MODULE -I/usr/local/apache/include -I../jk -	I/usr/java/include
-I/usr/java/include/irix -DIRIX  -c mod_jk.c
	cc: unrecognized option `-n32'
	cc: unrecognized option `-KPIC'
	In file included from ../jk/jk_util.h:66,
                 from mod_jk.c:90:
	../jk/jk_pool.h:116: parse error before `jk_pool_atom_t'
	mod_jk.c: In function `jk_handler':
	mod_jk.c:679: `jk_pool_atom_t' undeclared (first use in this
	mod_jk.c:679: (Each undeclared identifier is reported only once
	mod_jk.c:679: for each function it appears in.)
	mod_jk.c:679: parse error before `buf'
	mod_jk.c:680: `buf' undeclared (first use in this function)
	apxs:Break: Command failed with rc=65536

To unsubscribe, e-mail:
For additional commands, email:

View raw message