tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From AC <s...@lisea.com>
Subject Reloadable not working
Date Fri, 02 Feb 2001 18:12:11 GMT
Hi,
just a simple question.. I spend some times trying to disable the 
reloadable flax in my context. The server.xml configuration is:
(I'm using virtual hosting)

<Host name="testA.mydomain..net" >
                 <Context path="/tf"
                         docBase="webapps/tf"
                         debug="0"
                         crossContext="true"
                         trusted="false"
                         reloadable="false" >
                 </Context>
  </Host>

In this manner nothing happens. If you read the remarks on server.xml you 
notice that if you deploy your  application under  TOMCAT_HOME/webapps, the 
engine will use some default such as reloadable=true. So I move my 
application outside TOMCAT_HOME/webapps. After that the previous Jkmount 
rules didn't work at all and, while i can call directly a jsp, once I call 
a servlet, tomcat didn't respond and get 99.9% cpu time (I'm under FreeBsd 
4.2).
Killing, trying and starting some times, I get  my application  working 
outside TOMCAT_HOME/webapps (even if I had to use the ApJServMount instead 
of jkmount ) but, again, the reloadable flag didn't work.
Any hints???
By the way, I did the same test on a win2000, without apache on port 8080, 
but the reloadable flag didn't work again.
Where am I wrong?????
thank you
andrea





Mime
View raw message