tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Braden <mbra...@utenzi.com>
Subject RE: can´t build mod_jk under AIX :-(((
Date Thu, 01 Feb 2001 16:29:49 GMT
Have you compiled other code with gcc?

I have seen similar errors on HPUX.

I know that on HPUX, you also have to have GNU bin utils, which provides the
assembler and some other utils required to compile source.

Hope this helps.

Thanks,

Mike.

-----Original Message-----
From: rainer [mailto:rainer_schmidt@gmx.net]
Sent: Thursday, February 01, 2001 12:15 PM
To: tomcat-user@jakarta.apache.org
Subject: can´t build mod_jk under AIX :-(((


hi there!

i work on AIX 4.3.3 and with apache 1.13.14 and need zu build a mod_jk
but it doesn´t work. i am using java 1.3.0.
when i execute the apxs-tool described in the mod_jk-howto the linker
reports an error and stops.
/usr/local/apache/bin/apxs -o mod_jk.so -I../jk -I/usr/java130/include -c
*.c ../jk/*.c

it seems the gcc works fine, but then it happens:

ld -H512 -T512 -bhalt:4 -bM:SRE -bnoentry -bI:/usr/local/apache/libexec/http
d.exp -lc -o mod_jk.so jk_worker.o jk_util.o jk_uri_worker_map.o
jk_sockbuf.o jk_pool.o jk_nwmain.o jk_msg_buff.o jk_map.o jk_lb_worker.o
jk_jni_worker.o jk_connect.o jk_ajp13_worker.o jk_ajp13.o jk_ajp12_worker.o
mod_jk.o
ld: 0711-244 ERROR: No csects or exported symbols have been saved.
apxs:Break: Command failed with rc=8

i´m not very fluent in compiling and linking. Please, can somebody help me.
i already searched in this archive for solutions; some people got also
problems with building the module, but no one used AIX.

regards,
boris

ps: please cc me in an answering mail
zu.mir@gmx.at







---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, email: tomcat-user-help@jakarta.apache.org

Mime
View raw message