tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Suchi Somasekar <su...@ordinate.com>
Subject Re: JDBC realm
Date Fri, 23 Feb 2001 00:40:28 GMT
Thanks for your help. My problem was that my classpath was not set  to include
the Oracle driver which caused Tomcat to die when I started it. Once I fixed
that it is working fine.

Thanks
Suchithra


Tom Woteki wrote:

> Did you in fact set up the userTable and userRoleTables tables in Oracle and
> did you specify security constraints in your web.xml for the application?
> --
> Tom Woteki, a.k.a. Dr. Wo
> mail to:<drwo@woteki.com>
> 202-544-2743 (fax)
> http://www.woteki.com/wines <-- a pure Java, Apache-Tomcat web application
> running under MacOSX
> > From: Suchi Somasekar <suchi@ordinate.com>
> > Reply-To: tomcat-user@jakarta.apache.org
> > Date: Wed, 21 Feb 2001 12:31:52 -0500
> > To: tomcat-user@jakarta.apache.org
> > Subject: JDBC realm - Pls help
> >
> > Hi
> > I am a new user of tomcat and I am having trouble getting the JDBC realm
> > to work. I am using Tomcat 3.2.1 on Windows2000 and I am testing a small
> > sample application that I wrote. Everything including the user
> > authentication works great when I use the "SimpleRealm".
> > But, When I tried to use the JDBC realm the server will not start, it
> > just dies with no error messages, no log messages.
> > I have made absolutely no other changes except comment out the
> > SimpleRealm and include the JDBC realm information to the server.xml and
> > added the Oracle driver in tomcat/lib. The following is the relevant
> > portion of my server.xml
> >
> > <!--
> >       <RequestInterceptor
> >           className="org.apache.tomcat.request.SimpleRealm"
> >           debug="0" />
> >       -->
> >
> >      <RequestInterceptor
> >           className="org.apache.tomcat.request.JDBCRealm"
> >           debug="99"
> >    driverName="oracle.jdbc.driver.OracleDriver"
> >         connectionURL="jdbc:oracle:thin:@testserver:1521:TEST3"
> >           connectionName="readonly"
> >             connectionPassword="nowrites"
> >
> >           userTable="usernames"
> >           userNameCol="username"
> >           userCredCol="password"
> >    userRoleTable="userroles"
> >          roleNameCol="rolename" />
> >
> > Can someone please tell me what I am missing.
> >
> > Thanks
> > Suchithra
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> > For additional commands, email: tomcat-user-help@jakarta.apache.org
> >


Mime
View raw message