tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Suchi Somasekar <su...@ordinate.com>
Subject JDBC realm - Pls help
Date Wed, 21 Feb 2001 17:31:52 GMT
Hi
I am a new user of tomcat and I am having trouble getting the JDBC realm
to work. I am using Tomcat 3.2.1 on Windows2000 and I am testing a small
sample application that I wrote. Everything including the user
authentication works great when I use the "SimpleRealm".
But, When I tried to use the JDBC realm the server will not start, it
just dies with no error messages, no log messages.
I have made absolutely no other changes except comment out the
SimpleRealm and include the JDBC realm information to the server.xml and
added the Oracle driver in tomcat/lib. The following is the relevant
portion of my server.xml

<!--
        <RequestInterceptor
            className="org.apache.tomcat.request.SimpleRealm"
            debug="0" />
        -->

       <RequestInterceptor
            className="org.apache.tomcat.request.JDBCRealm"
            debug="99"
     driverName="oracle.jdbc.driver.OracleDriver"
          connectionURL="jdbc:oracle:thin:@testserver:1521:TEST3"
            connectionName="readonly"
              connectionPassword="nowrites"

            userTable="usernames"
            userNameCol="username"
            userCredCol="password"
     userRoleTable="userroles"
           roleNameCol="rolename" />


Can someone please tell me what I am missing.

Thanks
Suchithra



Mime
View raw message