tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "mathew" <mat...@spectrum.co.in>
Subject new user please correct me................
Date Mon, 05 Feb 2001 15:42:39 GMT
Hi

I read thru the tomcat documentation and this is what i understood.

Please correct me if there is any problem.

we are running

OS -R H LINUX 6.2

WebServer - Apache 1.3.14

Tomcat -3.2.1

and I

1. Copied the tomcat directory to /usr/
2. Since libexec directory was not there for apache  created libexec
directory
3. Copied mod_jk.so to the libexec directory.
4. Inserted "include /usr/tomcat/conf.mod_jk.conf" into httpd.conf of
apache.
5. Modified TOMCAT-HOME, JAVA-HOME, and ps in workers.properties.
6. Added the following block to server.xml
<Connector className="org.apache.tomcat.service.PoolTcpConnector">
    <Parameter name="handler " value =
"org.apache.tomcat.service.connector.Ajp13ConnectionHandler"/>
     <Parameter name="port" value="8009"/>
</Connector>


That's all with my installation.


Now I have 2 domains www.host1.com, www.host2.com and it is configured in
httpd.conf
and is running well with perl.

To enable them with servlets
1. Created servlets directory and copied WEB-INF and META-INF to the
directories.
2. Copied servlet classes to the classes directory in the WEB-INF directory.
3. Modified the server.xml with following

<Host name="www.host1.com" >
           <Context path="/servlet"
                    docBase="host1/servlets" />
        </Host>
<Host name="www.host2.com" >
           <Context path="/servlet"
                    docBase=" host2/servlets" />
        </Host>

It is working fine .Will this be enough, please advise me....


Max




Mime
View raw message