tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Fowler" <afow...@cc.edu>
Subject RE: Virtual Hosting and Startup as the machine startup...
Date Sat, 17 Feb 2001 21:59:24 GMT
Oh just realised,

You should probably download the latest Java SDK 1.2 v.3 (or 1.3).

My Prof' got it working in RedHat easily with the default
configuration(except ajp13 instead of ajp12)

Regards,
Adam.

----
Adam Fowler
Second year Computer Science undergraduate
University of Wales, Aberystwyth
Carroll College, WI, USA(2000-2001)
web: http://gucciboy.dyndns.org/aff9
e-mail: adamfowler@chillin.co.uk
"Every new beginning comes from some other beginning's end"
----


-----Original Message-----
From: Merwin Yap [mailto:merwin.yap@webphilippines.com.ph]
Sent: Thursday, February 08, 2001 3:53 AM
To: tomcat-user@jakarta.apache.org
Subject: Virtual Hosting and Startup as the machine startup...


I currently have jdk1.2.2,  tomcat3.2 using mod_jk working with Apache
running in  Red Hat Linux

I read about it, and have been trying stuff but i have failed... and
here are some questions... I know that these stuff have
might have been asked before but back then I was just startring and i
couldn't  care less since they were so complicated for me to
comprehend...

Virtual Hosting

- the faq seems to be using jserv rather than mod_jk, I know that both
httpd.conf and server must be edited.

here what i added in server.xml

<Context path="/survey"
                docBase="webapps/survey"
                defaultSessionTimeOut="30000"
                crossContext="false"
               debug="0"
                reloadable="true">
</Context>

<Host name="survey.com" >
      <Context path=""
                       docBase="webapp/survey" />
     <Context path="/survey"
                      docBase="webapps/ROOT" />
</Host>

Anything wrong???

here what i added in http.conf

<VirtualHost >
        DocumentRoot /home/webapp/jakarta-tomcat/webapps/survey
        ServerName survey.com
        JkMount  /*.jsp ajp12
        JkMount  /servlet/* ajp12
</VirtualHost>

--> httpd failed during reboot something to do with JkMount... !!!

************************************************************************

Starting Jakarta-Tomcat as Nobody as the Server Starts

    I read something about it and tried them but there is still
something missing...
I already made symlink like S83tomcat which i placed in etc/rc.d/ rc2 to
5
and K83 for rc0 ,rc1, and rc6 ... and i also have the file linked  named
tomcat
stored in etc/rc.d/init.d/  ? what could be still missing?

Should tomcat start before httpd???

hope to hear from you soon... I really need help...


Thanks! I appreciate the time you spent in answering my questions,,,

Thanks!
Merwin


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, email: tomcat-user-help@jakarta.apache.org



Mime
View raw message