tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Spyker, Andrew" <ASpy...@brightpod.com>
Subject servlet url-mapping problem - works in tomcat - fails in apache+t omcat
Date Mon, 29 Jan 2001 22:31:48 GMT
All,

I read archives of the mailing list and found a similar post, but the
solution didn't work.  I am trying to migrate from a JSP + servlet web
application I wrote and tested under Tomcat standalone to Apache + Tomcat.
I am running IBM Apache 1.3.6.3 and Tomcat 3.2.1 on NT with Sun Java SE 1.3.
I can't seem to get the servlet to be accessible under Apache.  It works
fine when I go directly to Tomcat as you can see below.  Also note that the
servlet from examples called snoop works both ways so it shouldn't be a
global configuration problem?  Can anyone point out what I am missing?

Works:
http://localhost:8080/<web app name>/<servlet name>
http://localhost:8080/examples/snoop
http://localhost/examples/servlet/snoop

Fails:
http://localhost/<web app name>/servlet/<servlet name>


My web.xml:
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application
2.2//EN" "http://java.sun.com/j2ee/dtds/web-app_2_2.dtd">

<web-app>
<servlet>
<servlet-name><servlet name></servlet-name>
<servlet-class><dotted.path.to.servlet></servlet-class>
<!--
<load-on-startup>1</load-on-startup>
-->
</servlet>
<servlet-mapping>
<servlet-name><servlet name></servlet-name>
<url-pattern>/<servlet-name></url-pattern>
 </servlet-mapping>
</web-app>

My server.xml:
<Context path="/<web app name>"
  docBase="webapps/<web app name>"
  crossContext="false"
  debug="0"
  reloadable="true">
</Context>

---
Andrew Spyker (aspyker@brightpod.com)

Mime
View raw message