tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ciot, Thierry" <thierry.c...@compuware.com>
Subject RE: UnsatisfiedLinkError (help)
Date Thu, 25 Jan 2001 21:26:58 GMT
The library is found but the signature for the method you are trying to call
does not exist.
Check the code.

Thierry

-----Original Message-----
From: Vishal Gharat [mailto:vgharat@telesciences.com]
Sent: Thursday, January 25, 2001 8:55 AM
To: tomcat
Subject: UnsatisfiedLinkError (help)


I am getting an exception "UnsatisfiedLinkError" whilst trying to call
the native method from a servlet.
Since the native method was in a separate class, I tried invoking the
method from a the main method from the same class. THIS WORKS PERFECTLY
FINE.

Intially, I thought it did not get the shared library. But, I tried
changing the name of the library in the "System.loadLibrary("mylib");"
And it did fail here. So  JVM not finding the library is not the case,
since the exception thrown in my case is when I invoke the native
method.

If anybody can help me on this issue...I would highly apprecaite that.

thanks
Vishal


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, email: tomcat-user-help@jakarta.apache.org

Mime
View raw message