tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Morahg, Yoav" <Ymor...@gist.com>
Subject RE: problem with classpath and .jar files
Date Tue, 23 Jan 2001 18:22:57 GMT
.jars go in the WEB-INF/lib directory, not WEB-INF/classes.

-Yoav

-----Original Message-----
From: André Alves [mailto:andref_alves@yahoo.com]
Sent: Tuesday, January 23, 2001 1:18 PM
To: tomcat-user@jakarta.apache.org
Subject: Re: problem with classpath and .jar files


 In winnt I placed .jar below of the /WEB-INF/classes/ and only
configured in wrapper.properties classpath for .jar and the program
functioned perfectly. I made this same configuration in redhat, but
it did not work. Somebody knows which can be the cause of this? 

--- Jeffry Guttadauro <jeff.guttadauro@abbott.com> escreveu: > Sorry,
but none that I know of.  If I think of anything, I will let
> you know,
> but it was my understanding that it should just work without any
> extra
> tweaking...  Good luck!
> 
> 
> 
> 
> 
> andref_alves@yahoo.com on 01/23/2001 11:05:41 AM
> Please respond to tomcat-user@jakarta.apache.org
> To: tomcat-user@jakarta.apache.org
> cc:
> Subject: Re: problem with classpath and .jar files
> 
> Hi Jeffry,
> 
> Is necessary some type of special configuration so that tomcat to
> find the class? Some thing as to configure worker.properties or
> wrapper.properties?
> 
> --- Jeffry Guttadauro <jeff.guttadauro@abbott.com> escreveu: > The
> .jar should go directly in the WEB-INF/lib directory.
> >
> >
> >
> >
> >
> > andref_alves@yahoo.com on 01/23/2001 10:36:41 AM
> > Please respond to tomcat-user@jakarta.apache.org
> > To: tomcat-user@jakarta.apache.org
> > cc:
> > Subject: problem with classpath and .jar files
> >
> > I have the following problem: I created a structure of
> directories
> > to
> > place mine .class and later generating one .jar. Below of
> > WEB-INF/classes I have the structure: /com/mycompany/class and in
> > this last directory I have mine .class... Wen I run tomcat,
> without
> > grouping the class in a .jar, the program functions perfectly,
> but
> > when I group the classes in a .jar, tomcat does not can to locate
> > the
> > .class. I tried to configure worker.properties and
> > wrapper.properties, but this did not advance in nothing. It would
> > like to know if somebody already had some problem similar to this
> > and
> > as I make to configure tomcat to use wrapper.properties or
> > worker.properties correctly. I am using Redhat 6.1 with apache
> > 1.3.12
> > and tomcat 3.2.1.
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Yahoo! Auctions - Buy the things you want at great prices.
> > http://auctions.yahoo.com/
> >
> >
>
---------------------------------------------------------------------
> > To unsubscribe, e-mail:
> tomcat-user-unsubscribe@jakarta.apache.org
> > For additional commands, email:
> tomcat-user-help@jakarta.apache.org
> >
> >
> >
> >
> >
> >
>
---------------------------------------------------------------------
> > To unsubscribe, e-mail:
> tomcat-user-unsubscribe@jakarta.apache.org
> > For additional commands, email:
> tomcat-user-help@jakarta.apache.org
> >
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Auctions - Buy the things you want at great prices.
> http://auctions.yahoo.com/
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, email: tomcat-user-help@jakarta.apache.org
> 
> 
> 
> 
>  


__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - Buy the things you want at great prices. 
http://auctions.yahoo.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, email: tomcat-user-help@jakarta.apache.org

Mime
View raw message