tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralph Jensen" <rjen...@ms56.url.com.tw>
Subject Re: beginner needs help(Compile error)
Date Tue, 02 Jan 2001 03:01:15 GMT
I tried it and the same happened. The reason was that on my system (LINUX)
the TOMCAT_HOME environment variable wasn't set and thus the classpath for
the build script wasn't constructed properly and thus the jar file
containing org.apache.tools.ant wasn't found. Look at the code of the build
script ( build.bat or build.sh ) to see the details.

There may be a better solution, but setting TOMCAT_HOME at the beginning of
the build script will solve the problem.

Ralph Jensen

----- Original Message -----
From: <SoftwareSolutions@endurance.co.uk>
To: <tomcat-user@jakarta.apache.org>
Sent: Sunday, December 31, 2000 12:00 AM
Subject: beginner needs help(Compile error)


> Dear Helper,
>
> I am running the application fine with the following commands...
>
> set TOMCAT_HOME=e:\foo\jakarta-tomcat-3.2.1
> set JAVA_HOME=e:\jdk1.3
> cd jakarta-tomcat-3.2.1\bin
> startup
> cd ..
> cd doc
> cd appdev
> cd sample
>
> The above outputs the following path info also...
>
> Using CLASSPATH:
e:\foo\jakarta-tomcat-3.2.1\classes;e:\foo\jakarta-tomcat-3.2.1
>
\lib\ant.jar;e:\foo\jakarta-tomcat-3.2.1\lib\jasper.jar;e:\foo\jakarta-tomc
at-3.
>
2.1\lib\jaxp.jar;e:\foo\jakarta-tomcat-3.2.1\lib\parser.jar;e:\foo\jakarta-
tomca
>
t-3.2.1\lib\servlet.jar;e:\foo\jakarta-tomcat-3.2.1\lib\webserver.jar;C:\Si
lverS
>
tream30\COMPILECACHE\LOCALHOST\DEVELOP_BEANS\CLASSES;C:\SilverStream30\LIB\
Silve
>
rServerAll.zip;c:\SilverStream30\lib\servlet.jar;c:\SilverStream30\jre\lib\
rt.ja
>
r;c:\SilverStream30\lib\silverdesignerall.zip;c:\SilverStream30\Docs\help\b
ooks\
>
TechCode\jsptech6;c:\SilverStream30\jre\lib\ext\jndi.jar;c:\SilverStream30\
lib\j
> avax_sql.zip;e:\jdk1.3\lib\tools.jar
>
> I am then typing build in the sample directory but here I come unstuck...
>
> E:\foo\jakarta-tomcat-3.2.1\doc\appdev\sample>build
> Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/tools/ant/
> Main
>
> Can you throw any light on this?
>
> Regards Charles
>
>
>
> Your email address says a lot about you.
> Express yourself @ another.com
> http://another.com/jump.jsp?destDesc=another.com/login.jsp?sig=393
>
>
>


---------------------------------------------------------------------------
-----


> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, email: tomcat-user-help@jakarta.apache.org


Mime
View raw message